aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/eog/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/eog/Makefile')
-rw-r--r--graphics/eog/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/graphics/eog/Makefile b/graphics/eog/Makefile
index 90d80493b2ca..d508901fdadf 100644
--- a/graphics/eog/Makefile
+++ b/graphics/eog/Makefile
@@ -3,14 +3,14 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/graphics/eog/Makefile,v 1.9 2005/10/04 03:00:35 ahze Exp $
+# $MCom: ports/graphics/eog/Makefile,v 1.29 2006/04/13 07:52:35 bland Exp $
#
PORTNAME= eog
-PORTVERSION= 2.12.3
+PORTVERSION= 2.14.1
CATEGORIES= graphics gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.12
+MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
@@ -18,12 +18,13 @@ COMMENT= The Eye Of Gnome image viewer
USE_BZIP2= yes
USE_GMAKE= yes
-USE_REINPLACE= yes
USE_GNOME= gnomeprefix gnomehack intlhack libgnomeprintui \
- librsvg2 desktopfileutils libgnomeui
+ librsvg2 desktopfileutils gnomedesktop
+USE_GETTEXT= yes
USE_X_PREFIX= yes
INSTALLS_OMF= yes
GNU_CONFIGURE= yes
+GNOME_DESKTOP_VERSION=2
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"