aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/epix/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/epix/Makefile')
-rw-r--r--graphics/epix/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/graphics/epix/Makefile b/graphics/epix/Makefile
index 44891f071e74..73102cb1f57e 100644
--- a/graphics/epix/Makefile
+++ b/graphics/epix/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= epix
-PORTVERSION= 1.2.14
+PORTVERSION= 1.2.15
CATEGORIES= graphics
MASTER_SITES= http://mathcs.holycross.edu/~ahwang/epix/
@@ -10,13 +10,13 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Creates math plots and line figures using easy-to-learn syntax
LICENSE= GPLv2 # (or later)
+LICENSE_FILE= ${WRKSRC}/COPYING
-USE_TEX= texmf:build
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
USES= gmake makeinfo tar:bzip2
-USE_TEX= latex dvipsk:build
+USE_TEX= latex dvipsk:build texmf:build
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-bash=${LOCALBASE}/bin/bash \
--with-runtime=${CXX}
@@ -26,7 +26,8 @@ INFO= epix
OPTIONS_DEFINE= DOCS
post-patch:
- @${REINPLACE_CMD} -e '/usepackage/s|pstricks,xcolor|pstricks,tikz,xcolor|' \
+ @${REINPLACE_CMD} -e \
+ '/usepackage/s|\(pstricks\),\(xcolor\)|\1,tikz,\2|' \
${WRKSRC}/doc/manual.tex
.include <bsd.port.mk>