aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/exact-image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/exact-image/Makefile')
-rw-r--r--graphics/exact-image/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/graphics/exact-image/Makefile b/graphics/exact-image/Makefile
index 65b3cd0dae4a..dbbc086d8946 100644
--- a/graphics/exact-image/Makefile
+++ b/graphics/exact-image/Makefile
@@ -37,6 +37,12 @@ PLIST_FILES= ${BINS:S|^|bin/|} %%SITE_PERL%%/ExactImage.so \
%%SITE_PERL%%/ExactImage.pm
PORT_VERBS= ExactImage ${BINS}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 600000
+BROKEN= Does not compile, missing endian.h header
+.endif
+
post-extract:
@${RM} -rf ${WRKSRC}/agg-2.4/
@@ -66,4 +72,4 @@ do-install:
${INSTALL_PROGRAM} ExactImage.so ${SITE_PERL}/;\
${INSTALL_DATA} ExactImage.pm ${SITE_PERL}/
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>