aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/freeglut/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/freeglut/Makefile')
-rw-r--r--graphics/freeglut/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/graphics/freeglut/Makefile b/graphics/freeglut/Makefile
index dcf31d5dd5fd..9287d58e6dcb 100644
--- a/graphics/freeglut/Makefile
+++ b/graphics/freeglut/Makefile
@@ -28,7 +28,6 @@ DOCS= download.html freeglut.html freeglut_logo.png \
progress.html structure.html
BINS= CallbackMaker Fractals Fractals_random Lorenz One shapes
-NO_STAGE= yes
.include <bsd.port.options.mk>
pre-configure:
@@ -43,17 +42,17 @@ post-build:
post-install:
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for FILE in ${DOCS}
- @${INSTALL_DATA} ${WRKSRC}/doc/${FILE} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/${FILE} ${STAGEDIR}${DOCSDIR}
.endfor
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
- @${INSTALL_DATA} ${WRKSRC}/progs/demos/Fractals/fractals.dat ${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/progs/demos/Fractals/fractals.dat ${STAGEDIR}${EXAMPLESDIR}
.for prog in ${BINS}
- @${INSTALL_PROGRAM} ${WRKSRC}/progs/demos/${prog}/.libs/${prog:L} ${EXAMPLESDIR}
+ @${INSTALL_PROGRAM} ${WRKSRC}/progs/demos/${prog}/.libs/${prog:L} ${STAGEDIR}${EXAMPLESDIR}
.endfor
@${ECHO_MSG} "===> Examples installed in ${EXAMPLESDIR}."
.endif