aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gdk-pixbuf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/gdk-pixbuf/Makefile')
-rw-r--r--graphics/gdk-pixbuf/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/graphics/gdk-pixbuf/Makefile b/graphics/gdk-pixbuf/Makefile
new file mode 100644
index 000000000000..cb9478ce8ae8
--- /dev/null
+++ b/graphics/gdk-pixbuf/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: gdk-pixbuf
+# Version required: 0.2
+# Date created: 5th October 1999
+# Whom: Ade Lovett <ade@lovett.com>
+#
+# $FreeBSD$
+#
+
+DISTNAME= gdk-pixbuf-0.2
+CATEGORIES= graphics gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/gdk-pixbuf
+
+MAINTAINER= ade@lovett.com
+
+LIB_DEPENDS= gnome.3:${PORTSDIR}/x11/gnomelibs
+
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_LIBTOOL= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/giflib" \
+ GLIB_CONFIG="${GLIB_CONFIG}" \
+ LIBS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>