aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/geos/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/geos/Makefile')
-rw-r--r--graphics/geos/Makefile38
1 files changed, 29 insertions, 9 deletions
diff --git a/graphics/geos/Makefile b/graphics/geos/Makefile
index 9156b719a3f8..018fe73e9238 100644
--- a/graphics/geos/Makefile
+++ b/graphics/geos/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= geos
-PORTVERSION= 3.3.0
-PORTREVISION= 2
+PORTVERSION= 3.3.1
CATEGORIES= graphics geography
MASTER_SITES= http://download.osgeo.org/geos/
@@ -22,18 +21,39 @@ USE_GMAKE= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-OPTIONS= PYTHON "Enable python bindings" off
+OPTIONS= PYTHON "Enable python bindings" off \
+ PHP "Enable php bindings" off \
+ RUBY "Enable ruby bindings" off
.include <bsd.port.options.mk>
+.if defined(WITH_PHP) || defined(WITH_PYTHON) || defined(WITH_RUBY)
+BUILD_DEPENDS+= swig1.3:${PORTSDIR}/devel/swig13
+.endif
+
.if defined(WITH_PYTHON)
-USE_PYTHON= yes
-CONFIGURE_ARGS+=--enable-python
-PLIST_SUB+= PYTHON=""
-BUILD_DEPENDS+= swig:${PORTSDIR}/devel/swig13
-PKGNAMESUFFIX= -python
+USE_PYTHON= yes
+CONFIGURE_ARGS+= --enable-python
+PLIST_SUB+= WITH_PYTHON=""
+.else
+PLIST_SUB+= WITH_PYTHON="@comment "
+.endif
+
+.if defined(WITH_PHP)
+BUILD_DEPENDS+= ${LOCALBASE}/bin/php-config:${PORTSDIR}/lang/php5
+CONFIGURE_ARGS+= --enable-php
+PLIST_SUB+= WITH_PHP=""
+.else
+PLIST_SUB+= WITH_PHP="@comment "
+.endif
+
+.if defined(WITH_RUBY)
+USE_RUBY= yes
+CONFIGURE_ARGS+= --enable-ruby
+CONFIGURE_ENV+= RUBY="${RUBY}"
+PLIST_SUB+= WITH_RUBY=""
.else
-PLIST_SUB+= PYTHON="@comment "
+PLIST_SUB+= WITH_RUBY="@comment "
.endif
post-install: