aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gimp-app/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/gimp-app/Makefile')
-rw-r--r--graphics/gimp-app/Makefile17
1 files changed, 13 insertions, 4 deletions
diff --git a/graphics/gimp-app/Makefile b/graphics/gimp-app/Makefile
index 1f474fa9b68f..1e368d3e10cc 100644
--- a/graphics/gimp-app/Makefile
+++ b/graphics/gimp-app/Makefile
@@ -7,8 +7,8 @@
#
PORTNAME= gimp-app
-DISTVERSION= 2.6.5
-PORTREVISION?= 1
+DISTVERSION= 2.6.6
+PORTREVISION?= 0
PORTEPOCH?= 1
CATEGORIES?= graphics gnome
MASTER_SITES= ftp://ftp.gimp.org/pub/%SUBDIR%/ \
@@ -45,7 +45,7 @@ USE_XORG= xpm xmu xext
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
USE_GNOME+= gnomehack intltool intlhack gtk20 libartlgpl2 ltverhack \
- desktopfileutils librsvg2
+ desktopfileutils
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
@@ -68,7 +68,8 @@ OPTIONS?= DEBUG "debugging" off \
DBUS "D-BUS support" on \
GVFS "Use GVFS for the URI plug-in" on \
HELPBROWSER "internal help browser" on \
- MP "multiple processor support" off
+ MP "multiple processor support" off \
+ RSVG "SVG format support" on
.endif
.include <bsd.port.pre.mk>
@@ -90,6 +91,14 @@ MLINKS= gimp-2.6.1 gimp.1 \
gimp-console-2.6.1 gimp-console.1 \
gimprc-2.6.5 gimprc.5
+.if defined(WITHOUT_RSVG)
+CONFIGURE_ARGS+= --without-librsvg
+PLIST_SUB+= SVG="@comment "
+.else
+USE_GNOME+= librsvg2
+PLIST_SUB+= SVG=""
+.endif
+
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+= --enable-debug
.endif