aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gimp-ufraw/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/gimp-ufraw/Makefile')
-rw-r--r--graphics/gimp-ufraw/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/graphics/gimp-ufraw/Makefile b/graphics/gimp-ufraw/Makefile
index add65a9e5255..615199ce404d 100644
--- a/graphics/gimp-ufraw/Makefile
+++ b/graphics/gimp-ufraw/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= gimp-ufraw
-PORTVERSION= 0.4
+PORTVERSION= 0.5
CATEGORIES= graphics gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ufraw
@@ -18,11 +18,21 @@ BUILD_DEPENDS= gimp:${PORTSDIR}/graphics/gimp
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff
+GNU_CONFIGURE= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= glib20 gnomehack intltool intlhack gtk20 libartlgpl2
WANT_GNOME= yes
-ALL_TARGET= build
-INSTALL_TARGET= install-admin
-.include <bsd.port.mk>
+CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
+ CFLAGS="${CFLAGS} -I ${LOCALBASE}/include"
+
+MAN1= ufraw.1
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} <= 600000
+BROKEN= "Needs memmem(3)"
+.endif
+
+.include <bsd.port.post.mk>