aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/glfw/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/glfw/Makefile')
-rw-r--r--graphics/glfw/Makefile39
1 files changed, 28 insertions, 11 deletions
diff --git a/graphics/glfw/Makefile b/graphics/glfw/Makefile
index 92c8515be613..f98201c3aaf5 100644
--- a/graphics/glfw/Makefile
+++ b/graphics/glfw/Makefile
@@ -2,23 +2,38 @@
# $FreeBSD$
PORTNAME= glfw
-PORTVERSION= 2.7.6
+PORTVERSION= 2.7.7
CATEGORIES= graphics
MASTER_SITES= SF
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= nemysis@gmx.ch
COMMENT= Portable framework for OpenGL development
+LICENSE= ZLIB
+
+LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
+ drm:${PORTSDIR}/graphics/libdrm \
+ xcb:${PORTSDIR}/x11/libxcb
+
USE_BZIP2= yes
-USE_XORG= x11 xext xrandr
-USE_GL= glu
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= compile.sh
ALL_TARGET= x11
INSTALL_TARGET= x11-install
+USE_XORG= x11 xau xdamage xdmcp xext xfixes xrandr xrender xxf86vm
+USE_GL= glu
USE_LDCONFIG= yes
MAKE_JOBS_UNSAFE=yes
+PLIST_FILES= include/GL/glfw.h \
+ lib/libglfw.a \
+ lib/libglfw.so \
+ lib/libglfw.so.0 \
+ libdata/pkgconfig/libglfw.pc
+
+PORTDOCS= *.pdf
+PORTEXAMPLES= Makefile.x11.in *.c *.tga
+
.include <bsd.port.options.mk>
post-extract:
@@ -29,22 +44,24 @@ post-patch:
's|/usr/X11R6|${LOCALBASE}| ; \
/SOFLAGS/s|-soname |-Wl,-soname,| ; \
/CFLAGS_THREAD/s|"-pthread"|"${PTHREAD_CFLAGS}"| ; \
- /LFLAGS_THREAD/s|"-pthread"|"${PTHREAD_LIBS}"|' ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+ /LFLAGS_THREAD/s|"-pthread"|"${PTHREAD_LIBS}"|' ${WRKSRC}/${CONFIGURE_SCRIPT}
@${REINPLACE_CMD} -e \
's|lib/pkgconfig|libdata/pkgconfig|g' ${WRKSRC}/lib/x11/Makefile.x11.in
post-install:
${INSTALL_DATA} ${WRKSRC}/lib/x11/libglfw.so ${PREFIX}/lib/libglfw.so.0
${LN} -sf ${PREFIX}/lib/libglfw.so.0 ${PREFIX}/lib/libglfw.so
+
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/docs/*.pdf ${DOCSDIR}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/docs/|} ${DOCSDIR}
.endif
+
.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/examples/Makefile.x11 ${EXAMPLESDIR}/makefile
- ${INSTALL_DATA} ${WRKSRC}/examples/*.c ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/examples/*.tga ${EXAMPLESDIR}
+ ${MKDIR} ${EXAMPLESDIR}
+.for e in ${PORTEXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/examples/${e} ${EXAMPLESDIR}
+.endfor
.endif
.include <bsd.port.mk>