aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gqview-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/gqview-devel/Makefile')
-rw-r--r--graphics/gqview-devel/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/graphics/gqview-devel/Makefile b/graphics/gqview-devel/Makefile
new file mode 100644
index 000000000000..2385adc98ddb
--- /dev/null
+++ b/graphics/gqview-devel/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: gqview
+# Date Created: 27 Oct 1998
+# Whom: Vanilla Pooh Shu <vanilla@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gqview
+PORTVERSION= 1.5.6
+PORTREVISION= 0
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= oliver@FreeBSD.org
+COMMENT= Another gtk2-based graphic file viewer
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
+
+USE_X_PREFIX= yes
+USE_GNOME= gnomehier gtk20
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+MAN1= gqview.1
+
+CONFLICTS= gqview-[0-9]*
+
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/gqview.desktop ${PREFIX}/share/gnome/apps/Graphics
+ ${INSTALL_DATA} ${WRKSRC}/gqview.png ${PREFIX}/share/gnome/pixmaps
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>