aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gstreamer1-plugins-gl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/gstreamer1-plugins-gl/Makefile')
-rw-r--r--graphics/gstreamer1-plugins-gl/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/graphics/gstreamer1-plugins-gl/Makefile b/graphics/gstreamer1-plugins-gl/Makefile
new file mode 100644
index 000000000000..c948ab0d2b01
--- /dev/null
+++ b/graphics/gstreamer1-plugins-gl/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTREVISION= 0
+CATEGORIES= graphics
+
+COMMENT= Gstreamer GL graphics plugin
+
+GST_PLUGIN= gl
+DIST= bad
+
+#USE_CSTD= gnu89
+#USE_CSTD= c11
+#USE_CXXSTD= c++11
+MAKE_ARGS+= V=1
+#USE_GCC= yes
+PLIST= ${.CURDIR}/pkg-plist
+
+MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer1-plugins
+
+pre-build:
+ @cd ${WRKSRC}/gst-libs/gst/gl && ${GMAKE}
+
+post-install:
+ @cd ${WRKSRC}/gst-libs/gst/gl && ${SETENV} DESTDIR=${STAGEDIR} \
+ INSTALL_TARGET=${INSTALL_TARGET} ${GMAKE} install
+
+.include "${MASTERDIR}/Makefile"