aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/imlib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/imlib/Makefile')
-rw-r--r--graphics/imlib/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/graphics/imlib/Makefile b/graphics/imlib/Makefile
index 210b8bb56892..c1c07d8c0d03 100644
--- a/graphics/imlib/Makefile
+++ b/graphics/imlib/Makefile
@@ -12,20 +12,22 @@ MASTER_SITES= ftp://ftp.enlightenment.org/enlightenment/enlightenment/libs/
MAINTAINER= vanilla@FreeBSD.org
-LIB_DEPENDS= png.3:${PORTSDIR}/graphics/png \
- jpeg.9:${PORTSDIR}/graphics/jpeg \
+LIB_DEPENDS= png.3:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
ungif.5:${PORTSDIR}/graphics/libungif \
gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_LIBTOOL= yes
-CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc/imlib
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ GLIB_CONFIG="${GLIB_CONFIG}" \
GTK_CONFIG="${GTK_CONFIG}" \
LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc/imlib \
+ --disable-gtktest
.include <bsd.port.mk>