aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/imlib2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/imlib2/Makefile')
-rw-r--r--graphics/imlib2/Makefile37
1 files changed, 22 insertions, 15 deletions
diff --git a/graphics/imlib2/Makefile b/graphics/imlib2/Makefile
index 1ae7fe824d35..9d55bd13d30c 100644
--- a/graphics/imlib2/Makefile
+++ b/graphics/imlib2/Makefile
@@ -1,32 +1,39 @@
-# New ports collection makefile for: imlib
-# Date created: 10 June 1997
-# Whom: Yukihiro Nakai <Nakai@Mlab.t.u-tokyo.ac.jp>
+# New ports collection makefile for: imlib2
+# Date created: 16 Oct 2000
+# Whom: >Jeremy Norris <ishmael27@home.com>
#
# $FreeBSD$
#
-PORTNAME= imlib
-PORTVERSION= 1.9.8.1
+PORTNAME= imlib2
+PORTVERSION= 1.0.0
CATEGORIES= graphics
-MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= stable/sources/imlib
+MASTER_SITES= ftp://ftp.enlightenment.org/pub/enlightenment/e17/libs/ \
+ http://www.us.rasterman.com/files/
-MAINTAINER= vanilla@FreeBSD.org
+MAINTAINER= ports@FreeBSD.ORG
LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
- ungif.5:${PORTSDIR}/graphics/libungif
+ ungif.5:${PORTSDIR}/graphics/libungif \
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ edb.1:${PORTSDIR}/databases/edb
-USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_GTK= yes
+USE_FREETYPE= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
-CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc/imlib
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-pre-configure:
- ${PERL} -pi -e "s^%%LOCALBASE%%^${LOCALBASE}^" ${WRKSRC}/imlib-config.in
+.include <bsd.port.pre.mk>
-.include <bsd.port.mk>
+.if defined(WITH_MMX) && (${ARCH} == "i386")
+CONFIGURE_ARGS= --enable-mmx
+.endif
+
+post-install:
+ strip ${PREFIX}/lib/libImlib2.so.1
+ strip ${PREFIX}/lib/loaders/filter/*
+ strip ${PREFIX}/lib/loaders/image/*
+.include <bsd.port.post.mk>