aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/kdegraphics3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/kdegraphics3/Makefile')
-rw-r--r--graphics/kdegraphics3/Makefile28
1 files changed, 24 insertions, 4 deletions
diff --git a/graphics/kdegraphics3/Makefile b/graphics/kdegraphics3/Makefile
index 07007be25070..02fd92036317 100644
--- a/graphics/kdegraphics3/Makefile
+++ b/graphics/kdegraphics3/Makefile
@@ -7,6 +7,7 @@
PORTNAME= kdegraphics
PORTVERSION= ${KDE_VERSION}
+PORTREVISION= 1
CATEGORIES= graphics kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
@@ -19,28 +20,45 @@ USE_BZIP2= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
-CONFIGURE_ARGS+=--without-kamera --without-imlib-config
.if defined(WITH_IMLIB) || defined(KDE_WITH_IMLIB)
USE_IMLIB= yes
PLIST_SUB+= IMLIB=""
+CONFIGURE_ARGS+= --with-imlib-config=${X11BASE}/bin
.else
WITHOUT_IMLIB= yes
-CONFIGURE_ARGS+=--without-imlib-config
PLIST_SUB+= IMLIB="@comment "
+CONFIGURE_ARGS+= --without-imlib-config
.endif
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
.include <bsd.port.pre.mk>
-# temporarily disable kamera, it requires gphoto2
+GPHOTO2_CONFIG= ${LOCALBASE}/bin/gphoto2-config
+
+.if exists(${GPHOTO2_CONFIG})
+WITH_GPHOTO2?= yes
+.endif
+
+.if defined(WITH_GPHOTO2) && ${WITH_GPHOTO2} == yes
+LIB_DEPENDS+= gphoto2.2:${PORTSDIR}/graphics/gphoto2
+PLIST_SUB+= KAMERA=""
+.else
PLIST_SUB+= KAMERA="@comment "
+pre-everything::
+ @${ECHO_MSG}
+ @${ECHO_MSG} "======================================================="
+ @${ECHO_MSG} "If you want to compile with digital camera support,"
+ @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_GPHOTO2=yes\""
+ @${ECHO_MSG} "======================================================="
+ @${ECHO_MSG}
+.endif
SANE_CONFIG= ${LOCALBASE}/bin/sane-config
.if exists(${SANE_CONFIG})
-WITH_SANE= yes
+WITH_SANE?= yes
.endif
.if defined(WITH_SANE) && ${WITH_SANE} == yes
@@ -50,8 +68,10 @@ PLIST_SUB+= SANE=""
PLIST_SUB+= SANE="@comment "
pre-everything::
@${ECHO_MSG}
+ @${ECHO_MSG} "======================================================="
@${ECHO_MSG} "If you want to compile with scanner (SANE) support,"
@${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_SANE=yes\""
+ @${ECHO_MSG} "======================================================="
@${ECHO_MSG}
.endif