aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/libGL/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/libGL/Makefile')
-rw-r--r--graphics/libGL/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/graphics/libGL/Makefile b/graphics/libGL/Makefile
index b1f0d35b7d19..1ed64ebf10ac 100644
--- a/graphics/libGL/Makefile
+++ b/graphics/libGL/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libGL
PORTVERSION= ${MESAVERSION}
+PORTREVISION= 1
CATEGORIES= graphics
COMMENT= OpenGL library that renders using GLX or DRI
@@ -16,10 +17,15 @@ LIB_DEPENDS+= drm:${PORTSDIR}/graphics/libdrm \
USE_XORG= glproto x11 xext xxf86vm xdamage xfixes dri2proto:both
+SUB_FILES= pkg-install pkg-deinstall
+
do-install:
${RM} -f ${WRKSRC}/include/GL/glu*.h
cd ${WRKSRC}/src/mesa; ${GMAKE} install-libgl
+post-install:
+ @PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+
.include "${.CURDIR}/bsd.mesalib.mk"
.include <bsd.port.pre.mk>