aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/libreatlas/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/libreatlas/Makefile')
-rw-r--r--graphics/libreatlas/Makefile56
1 files changed, 56 insertions, 0 deletions
diff --git a/graphics/libreatlas/Makefile b/graphics/libreatlas/Makefile
new file mode 100644
index 000000000000..b0be60877c80
--- /dev/null
+++ b/graphics/libreatlas/Makefile
@@ -0,0 +1,56 @@
+# Created by: lbartoletti <coder@tuxfamily.org>
+# $FreeBSD$
+
+PORTNAME= libreatlas
+PORTVERSION= 1.0.0a
+CATEGORIES= graphics geography
+MASTER_SITES= http://www.gaia-gis.it/gaia-sins/
+
+MAINTAINER= coder@tuxfamily.org
+COMMENT= Open Source Geography Education application
+
+LIB_DEPENDS= mspack:${PORTSDIR}/archivers/libmspack \
+ spatialite:${PORTSDIR}/databases/spatialite \
+ sqlite3:${PORTSDIR}/databases/sqlite3 \
+ pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
+ pcre:${PORTSDIR}/devel/pcre \
+ cairo:${PORTSDIR}/graphics/cairo \
+ geos:${PORTSDIR}/graphics/geos \
+ jbig:${PORTSDIR}/graphics/jbigkit \
+ jpeg:${PORTSDIR}/graphics/jpeg \
+ geotiff:${PORTSDIR}/graphics/libgeotiff \
+ rasterlite:${PORTSDIR}/graphics/librasterlite \
+ png15:${PORTSDIR}/graphics/png \
+ proj:${PORTSDIR}/graphics/proj \
+ tiff:${PORTSDIR}/graphics/tiff \
+ freetype:${PORTSDIR}/print/freetype2 \
+ expat:${PORTSDIR}/textproc/expat2 \
+ freexl:${PORTSDIR}/textproc/freexl \
+ fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
+ xcb:${PORTSDIR}/x11/libxcb
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_PKGCONFIG= build
+USE_GETTEXT= yes
+USE_ICONV= yes
+USE_XORG= ice pixman sm x11 xau xcomposite xcursor xdamage xdmcp xext \
+ xfixes xi xinerama xrandr xrender xxf86vm
+USE_GNOME= atk gdkpixbuf2 glib20 gtk20 pango
+USE_WX= 2.8
+WANT_UNICODE= yes
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+PLIST_FILES= bin/LibreAtlas
+
+DESKTOP_ENTRIES="LibreAtlas" "${COMMENT}" "" "LibreAtlas" \
+ "Graphics;Viewer;" true
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|wx-config|$${WX_CONFIG}|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|$$(libdir)/pkgconfig|$$(prefix)/libdata/pkgconfig|' \
+ ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>