aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/libsixel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/libsixel/Makefile')
-rw-r--r--graphics/libsixel/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/graphics/libsixel/Makefile b/graphics/libsixel/Makefile
new file mode 100644
index 000000000000..5ed231607fc2
--- /dev/null
+++ b/graphics/libsixel/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= libsixel
+PORTVERSION= 20140422
+CATEGORIES= graphics
+
+MAINTAINER= sue@iwmt.org
+COMMENT= A encoder/decoder library for DEC SIXEL graphics
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= saitoha
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= 8bd21f7
+
+GNU_CONFIGURE= yes
+
+PORTDOCS= README.md
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libsixel.so.0
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>