aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/nip2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/nip2/Makefile')
-rw-r--r--graphics/nip2/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/graphics/nip2/Makefile b/graphics/nip2/Makefile
index 03381483b59e..3a9d0dc20faa 100644
--- a/graphics/nip2/Makefile
+++ b/graphics/nip2/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= nip2
-PORTVERSION= 8.6.0
-PORTREVISION= 2
+PORTVERSION= 8.7.0
+DISTVERSIONPREFIX= v
CATEGORIES= graphics
-MASTER_SITES= https://github.com/${GH_ACCOUNT}/${PORTNAME}/releases/download/v${PORTVERSION}/
MAINTAINER= danilo@FreeBSD.org
COMMENT= Graphical user interface for VIPS
@@ -18,19 +17,22 @@ LIB_DEPENDS= libvips.so:graphics/vips \
libfreetype.so:print/freetype2
RUN_DEPENDS= xdg-open:devel/xdg-utils
-USES= bison desktop-file-utils dos2unix gettext gmake pkgconfig \
+USES= autoreconf:build bison desktop-file-utils dos2unix gettext gmake gnome pkgconfig \
shared-mime-info
+
DOS2UNIX_GLOB= *.def
USE_GNOME= cairo gdkpixbuf2 gnomemimedata gtk20 libxml2
-GNU_CONFIGURE= yes
+HAS_CONFIGURE= yes
+CONFIGURE_SCRIPT= ./autogen.sh
CONFIGURE_ARGS= --disable-update-desktop
LDFLAGS+= -lm
-GH_ACCOUNT= jcupitt
+USE_GITHUB= yes
+GH_ACCOUNT= libvips
SUB_FILES= run-nip2.sh
-OPTIONS_DEFINE= DOCS FFTW GOFFICE GRAPHVIZ GSF GSL
+OPTIONS_DEFINE= FFTW GOFFICE GRAPHVIZ GSF GSL
OPTIONS_DEFAULT= FFTW GOFFICE GRAPHVIZ GSF GSL
FFTW_LIB_DEPENDS= libfftw3.so:math/fftw3