aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/ogle/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/ogle/Makefile')
-rw-r--r--graphics/ogle/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/graphics/ogle/Makefile b/graphics/ogle/Makefile
index 93e0c72cca4a..1f54838de3ba 100644
--- a/graphics/ogle/Makefile
+++ b/graphics/ogle/Makefile
@@ -19,8 +19,6 @@ LIB_DEPENDS= a52.0:${PORTSDIR}/audio/liba52 \
xml2.5:${PORTSDIR}/textproc/libxml2
USE_XLIB= yes
-USE_AUTOCONF= yes
-USE_AUTOMAKE= yes
USE_GMAKE= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include"
@@ -51,6 +49,10 @@ post-patch:
.endif
@${PERL} -pi -e "s|%%X11BASE%%|${X11BASE}|" ${WRKSRC}/scripts/ogle.in
+pre-configure:
+ @${TOUCH} `find -E ${WRKSRC} -regex ".*Makefile\.(am|in)"`
+ @${TOUCH} ${WRKSRC}/configure.in ${WRKSRC}/configure
+
post-configure:
@${LN} -sf ${LOCALBASE}/bin/libtool ${WRKSRC}