aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/osg-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/osg-devel/Makefile')
-rw-r--r--graphics/osg-devel/Makefile77
1 files changed, 33 insertions, 44 deletions
diff --git a/graphics/osg-devel/Makefile b/graphics/osg-devel/Makefile
index 63d322f68da7..8417367d010d 100644
--- a/graphics/osg-devel/Makefile
+++ b/graphics/osg-devel/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Open Scene Graph
-# Date created: 26 Apr 2001
-# Whom: Randall Hopper <aa8vb@nc.rr.com>
-#
+# Created by: Randall Hopper <aa8vb@nc.rr.com>
# $FreeBSD$
-#
PORTNAME= osg
PORTVERSION= 3.1.3
@@ -24,9 +20,8 @@ LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
CONFLICTS= osg-[0-9]*
USE_ZIP= yes
-USES= cmake
+USES= cmake pkgconfig
USE_GL= gl glu
-USE_GNOME= pkgconfig
USE_XORG= x11
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
@@ -38,21 +33,15 @@ PLIST_SUB= OSG_VERSION=${PORTVERSION} \
PORTSCOUT= limitw:1,odd
-OPTIONS= CURL "Support for cURL" off \
- FREETYPE "Support for FreeType" on \
- GDAL "Support for GDAL" off \
- GIF "Support for giflib" on \
- INVENTOR "Support for SGI OpenInventor" off \
- JASPER "Support for JPEG2000" off \
- XINE "Support for Xine" off \
- ITK "Support for InsightToolkit" off \
- VNC "Support for LibVNCServer" off \
- OPENEXR "Support for OpenEXR" off \
- FFMPEG "Support for FFmpeg" off \
- SVG "Support for SVG through librsvg2" off \
- PDF "Support for PDF through poppler" off \
- XRANDR "Use Xrandr" on \
- SDL "Use SDL (joystick support in present3d)" off
+OPTIONS_DEFINE= CURL FREETYPE GDAL GIF INVENTOR JASPER XINE ITK \
+ VNC OPENEXR FFMPEG SVG PDF XRANDR SDL
+GDAL_DESC= GDAL support
+INVENTOR_DESC= SGI OpenInventor support
+ITK_DESC= InsightToolkit support
+VNC_DESC= LibVNCServer support
+SDL_DESC= Use SDL (joystick support in present3d)
+
+OPTIONS_DEFAULT= FREETYPE GIF XRANDR
# broken (openvrml from ports is too old)
# OPENVRML "Support for OpenVRML" off
@@ -65,7 +54,7 @@ FORCE_IGNORE+= COLLADA Performer OurDCMTK XUL FBX GTA # not in ports
FORCE_REQUIRE= Threads OpenGL X11 JPEG PNG TIFF ZLIB # common & lightweight
# options that affect FIND_PACKAGE
-.if defined(WITH_CURL)
+.if ${PORT_OPTIONS:MCURL}
FORCE_REQUIRE+= CURL
LIB_DEPENDS+= curl.6:${PORTSDIR}/ftp/curl
PLIST_SUB+= CURL=""
@@ -74,7 +63,7 @@ FORCE_IGNORE+= CURL
PLIST_SUB+= CURL="@comment "
.endif
-.if !defined(WITHOUT_FREETYPE)
+.if ${PORT_OPTIONS:MFREETYPE}
FORCE_REQUIRE+= FreeType
LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2
PLIST_SUB+= FREETYPE=""
@@ -83,7 +72,7 @@ FORCE_IGNORE+= FreeType
PLIST_SUB+= FREETYPE="@comment "
.endif
-.if defined(WITH_GDAL)
+.if ${PORT_OPTIONS:MGDAL}
FORCE_REQUIRE+= GDAL
LIB_DEPENDS+= gdal.17:${PORTSDIR}/graphics/gdal
PLIST_SUB+= GDAL=""
@@ -92,7 +81,7 @@ FORCE_IGNORE+= GDAL
PLIST_SUB+= GDAL="@comment "
.endif
-.if defined(WITH_GIF)
+.if ${PORT_OPTIONS:MGIF}
FORCE_REQUIRE+= GIFLIB
LIB_DEPENDS+= gif.5:${PORTSDIR}/graphics/giflib
PLIST_SUB+= GIF=""
@@ -101,7 +90,7 @@ FORCE_IGNORE+= GIFLIB
PLIST_SUB+= GIF="@comment "
.endif
-.if defined(WITH_INVENTOR)
+.if ${PORT_OPTIONS:MINVENTOR}
FORCE_REQUIRE+= Inventor
BUILD_DEPENDS+= ${LOCALBASE}/lib/libInventor.so:${PORTSDIR}/graphics/inventor
RUN_DEPENDS+= ${LOCALBASE}/lib/libInventor.so:${PORTSDIR}/graphics/inventor
@@ -111,7 +100,7 @@ FORCE_IGNORE+= Inventor
PLIST_SUB+= INVENTOR="@comment "
.endif
-.if defined(WITH_JASPER)
+.if ${PORT_OPTIONS:MJASPER}
FORCE_REQUIRE+= Jasper
LIB_DEPENDS+= jasper.4:${PORTSDIR}/graphics/jasper
PLIST_SUB+= JASPER=""
@@ -120,7 +109,7 @@ FORCE_IGNORE+= Jasper
PLIST_SUB+= JASPER="@comment "
.endif
-#.if defined(WITH_OPENVRML)
+#.if ${PORT_OPTIONS:MOPENVRML}
#FORCE_REQUIRE+= OpenVRML
#LIB_DEPENDS+= openvrml.8:${PORTSDIR}/www/openvrml
#PLIST_SUB+= OPENVRML=""
@@ -129,7 +118,7 @@ FORCE_IGNORE+= OpenVRML
PLIST_SUB+= OPENVRML="@comment "
#.endif
-.if defined(WITH_XINE)
+.if ${PORT_OPTIONS:MXINE}
FORCE_REQUIRE+= Xine
LIB_DEPENDS+= xine.2:${PORTSDIR}/multimedia/libxine
PLIST_SUB+= XINE=""
@@ -138,7 +127,7 @@ FORCE_IGNORE+= Xine
PLIST_SUB+= XINE="@comment "
.endif
-.if defined(WITH_ITK)
+.if ${PORT_OPTIONS:MITK}
FORCE_REQUIRE+= ITK
BUILD_DEPENDS+= ${LOCALBASE}/lib/InsightToolkit/UseITK.cmake:${PORTSDIR}/science/InsightToolkit
RUN_DEPENDS+= ${LOCALBASE}/lib/InsightToolkit/UseITK.cmake:${PORTSDIR}/science/InsightToolkit
@@ -149,7 +138,7 @@ FORCE_IGNORE+= ITK
PLIST_SUB+= ITK="@comment "
.endif
-.if defined(WITH_VNC)
+.if ${PORT_OPTIONS:MVNC}
FORCE_REQUIRE+= LibVNCServer
LIB_DEPENDS+= vncserver.0:${PORTSDIR}/net/libvncserver
PLIST_SUB+= VNC=""
@@ -158,7 +147,7 @@ FORCE_IGNORE+= LibVNCServer
PLIST_SUB+= VNC="@comment "
.endif
-.if defined(WITH_OPENEXR)
+.if ${PORT_OPTIONS:MOPENEXR}
FORCE_REQUIRE+= OpenEXR
LIB_DEPENDS+= IlmImf.6:${PORTSDIR}/graphics/OpenEXR
PLIST_SUB+= OPENEXR=""
@@ -167,7 +156,7 @@ FORCE_IGNORE+= OpenEXR
PLIST_SUB+= OPENEXR="@comment "
.endif
-.if defined(WITH_FFMPEG)
+.if ${PORT_OPTIONS:MFFMPEG}
FORCE_REQUIRE+= FFmpeg
LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
PLIST_SUB+= FFMPEG=""
@@ -176,7 +165,7 @@ FORCE_IGNORE+= FFmpeg
PLIST_SUB+= FFMPEG="@comment "
.endif
-.if defined(WITH_SDL)
+.if ${PORT_OPTIONS:MSDL}
FORCE_REQUIRE+= SDL
USE_SDL= sdl
.else
@@ -184,7 +173,7 @@ FORCE_IGNORE+= SDL
.endif
# options that affect PKG_CHECK_MODULES
-.if defined(WITH_SVG)
+.if ${PORT_OPTIONS:MSVG}
FORCE_REQUIRE+= RSVG
LIB_DEPENDS+= rsvg-2:${PORTSDIR}/graphics/librsvg2
PLIST_SUB+= SVG=""
@@ -193,7 +182,7 @@ FORCE_IGNORE+= RSVG
PLIST_SUB+= SVG="@comment "
.endif
-.if defined(WITH_PDF)
+.if ${PORT_OPTIONS:MPDF}
FORCE_REQUIRE+= Poppler-glib
LIB_DEPENDS+= poppler-glib.8:${PORTSDIR}/graphics/poppler-glib
PLIST_SUB+= PDF=""
@@ -202,23 +191,23 @@ FORCE_IGNORE+= Poppler-glib
PLIST_SUB+= PDF="@comment "
.endif
-.if defined(WITH_SVG) || defined(WITH_PDF)
+.if ${PORT_OPTIONS:MSVG} || ${PORT_OPTIONS:MPDF}
LIB_DEPENDS+= cairo.2:${PORTSDIR}/graphics/cairo
.endif
# other options
-.if defined(WITHOUT_XRANDR)
-CMAKE_ARGS+= -DOSGVIEWER_USE_XRANDR:BOOL=OFF
-.else
+.if ${PORT_OPTIONS:MXRANDR}
CMAKE_ARGS+= -DOSGVIEWER_USE_XRANDR:BOOL=ON
USE_XORG+= xrandr
+.else
+CMAKE_ARGS+= -DOSGVIEWER_USE_XRANDR:BOOL=OFF
.endif
-.if defined(WITHOUT_XRANDR)
-CMAKE_ARGS+= -DOSGVIEWER_USE_XRANDR:BOOL=OFF
-.else
+.if ${PORT_OPTIONS:MXRANDR}
CMAKE_ARGS+= -DOSGVIEWER_USE_XRANDR:BOOL=ON
USE_XORG+= xrandr
+.else
+CMAKE_ARGS+= -DOSGVIEWER_USE_XRANDR:BOOL=OFF
.endif
post-patch: