aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/p5-Image-Math-Constrain/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/p5-Image-Math-Constrain/Makefile')
-rw-r--r--graphics/p5-Image-Math-Constrain/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/graphics/p5-Image-Math-Constrain/Makefile b/graphics/p5-Image-Math-Constrain/Makefile
new file mode 100644
index 000000000000..4ada1f52a306
--- /dev/null
+++ b/graphics/p5-Image-Math-Constrain/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Image-Math-Constrain
+# Date created: 8 September 2007
+# Whom: coryking
+#
+# $FreeBSD$
+#
+
+PORTNAME= Image-Math-Constrain
+PORTVERSION= 1.01
+CATEGORIES= graphics perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Image
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= coryking@mozimedia.com
+COMMENT= Scaling math used in image size constraining (such as thumbnails)
+
+BUILD_DEPENDS= p5-PathTools>=3.25:${PORTSDIR}/devel/p5-PathTools
+RUN_DEPENDS= p5-PathTools>=3.25:${PORTSDIR}/devel/p5-PathTools
+
+PERL_CONFIGURE= yes
+
+MAN3= Image::Math::Constrain.3
+
+.include <bsd.port.mk>