aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/p5-PGPLOT/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/p5-PGPLOT/Makefile')
-rw-r--r--graphics/p5-PGPLOT/Makefile24
1 files changed, 10 insertions, 14 deletions
diff --git a/graphics/p5-PGPLOT/Makefile b/graphics/p5-PGPLOT/Makefile
index 6b30f67cbefa..92bbff71cde4 100644
--- a/graphics/p5-PGPLOT/Makefile
+++ b/graphics/p5-PGPLOT/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= pgperl
-PORTVERSION= 2.20
-PORTREVISION= 1
+PORTVERSION= 2.21
CATEGORIES= graphics perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:KGB
@@ -16,24 +15,21 @@ DISTNAME= PGPLOT-${PORTVERSION}
MAINTAINER= perl@FreeBSD.org
COMMENT= A perl5 extension which makes available the pgplot library
+BUILD_DEPENDS= p5-ExtUtils-F77>=1.13:${PORTSDIR}/lang/p5-F77
LIB_DEPENDS= pgplot.5:${PORTSDIR}/graphics/pgplot
-BUILD_DEPENDS= ${SITE_PERL}/ExtUtils/F77.pm:${PORTSDIR}/lang/p5-F77
-
-MAN3= PGPLOT.3
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+INSTALL_TARGET= pure_install
+SCRIPTS_ENV= PERL=${PERL}
USE_FORTRAN= g77
USE_PERL5= yes
-SCRIPTS_ENV= PERL=${PERL}
-INSTALL_TARGET= pure_install
-.include <bsd.port.pre.mk>
+MAN3= PGPLOT.3
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-.ifndef(NOPORTDOCS)
+.if !defined(NOPORTEXAMPLES)
post-install:
- @${MKDIR} ${EXAMPLESDIR}
- @(cd ${WRKSRC}; ${INSTALL_DATA} LICENSE test* \
- ${EXAMPLESDIR})
+ ${MKDIR} ${EXAMPLESDIR}/
+ cd ${WRKSRC}/ && ${INSTALL_DATA} LICENSE test* ${EXAMPLESDIR}/
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>