aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/panoglview/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/panoglview/Makefile')
-rw-r--r--graphics/panoglview/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/graphics/panoglview/Makefile b/graphics/panoglview/Makefile
index daafe28996f5..f36f1d748592 100644
--- a/graphics/panoglview/Makefile
+++ b/graphics/panoglview/Makefile
@@ -11,13 +11,14 @@ MAINTAINER= ii@any.com.ru
COMMENT= Panorama viewer using OpenGL
USES= gmake
+USE_GL= glu
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-unicode
CONFIGURE_ENV= WX_CONFIG_NAME=${WX_CONFIG} \
PATH="$${PATH}:${LOCALBASE}/bin"
-LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib
-CFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
-CXXFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include -ftemplate-depth-64
-CONFIGURE_ARGS= --with-unicode
+CFLAGS+= -I${LOCALBASE}/include
+CXXFLAGS+= -I${LOCALBASE}/include -ftemplate-depth-64
+LIBS+= -L${LOCALBASE}/lib -lGLU -lGL
USE_WX= 2.8
WX_UNICODE= yes