aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/pgplot/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/pgplot/Makefile')
-rw-r--r--graphics/pgplot/Makefile75
1 files changed, 68 insertions, 7 deletions
diff --git a/graphics/pgplot/Makefile b/graphics/pgplot/Makefile
index 9e4086712414..6e93eadc3abd 100644
--- a/graphics/pgplot/Makefile
+++ b/graphics/pgplot/Makefile
@@ -7,30 +7,91 @@
PORTNAME= pgplot
PORTVERSION= 5.2.2
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.astro.caltech.edu/pub/pgplot/
DISTNAME= ${PORTNAME}${PORTVERSION:R}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= bf@FreeBSD.org
COMMENT= A C/FORTRAN library for drawing graphs on a variety of display devices
LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png
MAKE_JOBS_UNSAFE= yes
-USE_PERL5_BUILD=yes
+USE_FORTRAN= yes
USE_LDCONFIG= yes
+USE_XORG= x11 xproto xt
+
+MAKE_ENV= SSP_CFLAGS=
+SUFFIXES= flib clib bin
WRKSRC= ${WRKDIR}/${PORTNAME}
.include <bsd.port.pre.mk>
-USE_XORG= x11 xproto xt
-USE_FORTRAN= yes
+.ifndef(NOPORTDATA)
+PORTDATA= grfont.dat
+.endif
+
+.ifndef(NOPORTDOCS)
+DOCS= cpg/cpgplot.doc pgplot-routines.tex pgplot.doc pgplot.html \
+ readme.pgdisp rgb.txt
+SUFFIXES+= doc
+PORTDOCS= ${DOCS:C|.*/||}
+USE_PERL5_BUILD= yes
+.endif
-post-install:
+.ifndef(NOPORTEXAMPLES)
+EXAMPLES= Makefile.demo cpg/cpgdemo.c examples/pgdemo*.f
+PORTEXAMPLES= ${EXAMPLES:C|.*/||}
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local/bin/perl|${PERL}|' \
+ ${WRKSRC}/makehtml ${WRKSRC}/maketex
+ @${REINPLACE_CMD} -e 's|png_ptr->jmpbuf|png_jmpbuf(png_ptr)|' \
+ ${WRKSRC}/drivers/pndriv.c
+ @${REINPLACE_CMD} -e 's|/usr/local/pgplot|${DATADIR}|g' \
+ ${WRKSRC}/src/grgfil.f
+ @cd ${FILESDIR}; ${CP} Makefile* drivers.list grexec.f ${WRKSRC}
+ @${CP} ${WRKSRC}/src/*.inc ${WRKSRC}
+
+do-build:
+.for s in ${SUFFIXES}
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} \
+ Makefile.${s} ${_MAKE_JOBS} ${MAKE_ARGS}
+.endfor
+
+do-install:
+ @cd ${WRKSRC}; \
+ ${INSTALL_PROGRAM} pgxwin_server pgdisp ${PREFIX}/bin; \
+ ${INSTALL_LIB} *.a *.so.5* ${PREFIX}/lib; \
+ ${INSTALL_DATA} cpgplot.h ${PREFIX}/include
.for f in libcpgplot.so libpgplot.so
- ${LN} -sf $f.5 ${PREFIX}/lib/$f
+ @${LN} -sf ${f}.5 ${PREFIX}/lib/${f}
.endfor
+.ifndef(NOPORTDATA)
+ @${MKDIR} ${DATADIR}
+ @cd ${WRKSRC}; ${INSTALL_DATA} ${PORTDATA} ${DATADIR}
+.endif
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC}; ${CP} pgdispd/aaaread.me readme.pgdisp; \
+ ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.endif
+.ifndef(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ @cd ${WRKSRC}; ${INSTALL_DATA} ${EXAMPLES} ${EXAMPLESDIR}
+.endif
+
+.if defined(MAINTAINER_MODE) && !defined(BATCH)
+
+check test: build
+ @cd ${WRKSRC}; ${CP} cpg/cpgdemo.c examples/pgdemo*.f ${WRKSRC}; \
+ ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} \
+ Makefile.demo ${_MAKE_JOBS} ${MAKE_ARGS}
+ @${SETENV} LD_LIBRARY_PATH="${LOCALBASE}/lib:${WRKSRC}" \
+ PGPLOT_DIR="${WRKSRC}" PGPLOT_DEV="/xwin" ${WRKSRC}/cpgdemo
+.endif
.include <bsd.port.post.mk>