aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/pixieplus/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/pixieplus/Makefile')
-rw-r--r--graphics/pixieplus/Makefile21
1 files changed, 14 insertions, 7 deletions
diff --git a/graphics/pixieplus/Makefile b/graphics/pixieplus/Makefile
index 6b7a74316aa5..d06701fa5bbe 100644
--- a/graphics/pixieplus/Makefile
+++ b/graphics/pixieplus/Makefile
@@ -7,27 +7,34 @@
PORTNAME= pixieplus
PORTVERSION= 0.5.4.1
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= graphics kde
MASTER_SITES= http://people.fruitsalad.org/avleeuwen/distfiles/${PORTNAME}/
MAINTAINER= ports@FreeBSD.org
COMMENT= A free, fast, and feature packed image browser and viewer for KDE
-LIB_DEPENDS= Magick.10:${PORTSDIR}/graphics/ImageMagick \
- ungif.5:${PORTSDIR}/graphics/libungif
+LIB_DEPENDS= GraphicsMagick:${PORTSDIR}/graphics/GraphicsMagick \
+ ungif:${PORTSDIR}/graphics/libungif
USE_AUTOTOOLS= libtool:15
-USE_GMAKE= yes
USE_KDELIBS_VER=3
INSTALLS_SHLIB= yes
USE_BZIP2= yes
+ALL_TARGET= -j`${SYSCTL} -n hw.ncpu`
.include <bsd.port.pre.mk>
post-patch:
- @${CP} ${FILESDIR}/blob_private.h ${WRKSRC}/app/
- @${CP} ${FILESDIR}/exception_private.h ${WRKSRC}/app/
- @${CP} ${FILESDIR}/image_private.h ${WRKSRC}/app/
+ # Massaging to use GraphicsMagick
+ ${REINPLACE_CMD} -e \
+ "s,INCLUDES =.*,INCLUDES=`${LOCALBASE}/bin/GraphicsMagick-config \
+ --cppflags` -I${LOCALBASE}/include," -e \
+ "s|-lMagick -ltiff|`${LOCALBASE}/bin/GraphicsMagick-config \
+ --libs`|" ${WRKSRC}/app/Makefile.in
+ ${REINPLACE_CMD} -e 's,<api.h>,<magick/api.h>,' \
+ ${WRKSRC}/app/*.h ${WRKSRC}/app/*.cpp
+ ${REINPLACE_CMD} -e s,Magick-config,GraphicsMagick-config,g -e s,6.0.0,1.1.10, \
+ ${WRKSRC}/configure
.include <bsd.port.post.mk>