aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/plotutils/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/plotutils/Makefile')
-rw-r--r--graphics/plotutils/Makefile23
1 files changed, 14 insertions, 9 deletions
diff --git a/graphics/plotutils/Makefile b/graphics/plotutils/Makefile
index c99905c50759..6993f073d4be 100644
--- a/graphics/plotutils/Makefile
+++ b/graphics/plotutils/Makefile
@@ -6,22 +6,27 @@
#
PORTNAME= plotutils
-PORTVERSION= 2.3
+PORTVERSION= 2.4.1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_GNU}
-MASTER_SITE_SUBDIR= plotutils
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= chuckr@FreeBSD.org
-USE_XLIB= yes
+LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png
+
+USE_NEWGCC= yes
+USE_MOTIF= yes
USE_LIBTOOL= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ MOTIFLIB="${MOTIFLIB}" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --enable-libplotter --enable-libxmi --with-motif
INSTALLS_SHLIB= yes
-USE_NEWGCC= yes
-CONFIGURE_ARGS= --enable-libplotter --enable-libxmi
-MAN1= ode.1 plot.1 spline.1 tek2plot.1
-USE_MOTIF= yes
-CONFIGURE_ARGS+= --with-motif
-CONFIGURE_ENV= MOTIFLIB="${MOTIFLIB}"
+MAN1= ode.1 plot.1 plotfont.1 spline.1 tek2plot.1
+
+pre-patch:
+ @${PERL} -pi -e 's|-lXm |\$$\{MOTIFLIB\} |g' ${WRKSRC}/configure
.include <bsd.port.mk>