aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/pngcheck/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/pngcheck/Makefile')
-rw-r--r--graphics/pngcheck/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/graphics/pngcheck/Makefile b/graphics/pngcheck/Makefile
index 847be53f422a..d17df3e671fb 100644
--- a/graphics/pngcheck/Makefile
+++ b/graphics/pngcheck/Makefile
@@ -10,25 +10,27 @@ MASTER_SITES= SF/png-mng/${PORTNAME}/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Checks the integrity of PNG images
-LICENSE= MIT GPLv2
-LICENSE_COMB= dual
+LICENSE= MIT GPLv2+
+LICENSE_COMB= multi
+LICENSE_FILE_GPLv2+ = ${WRKSRC}/gpl/COPYING
MAKEFILE= Makefile.unx
MAKE_ARGS= CC="${CC}" LD="${CC}" CFLAGS="${CFLAGS} -DUSE_ZLIB" LIBS="-lz"
PORTDOCS= CHANGELOG README
-OPTIONS_DEFINE= DOCS
-
PLIST_FILES= bin/pngcheck \
bin/pngsplit \
bin/png-fix-IDAT-windowsize
+OPTIONS_DEFINE= DOCS
+
do-install:
.for f in pngcheck pngsplit png-fix-IDAT-windowsize
${INSTALL_PROGRAM} ${WRKSRC}/${f} ${STAGEDIR}${PREFIX}/bin/
.endfor
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}