aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/pngquant/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/pngquant/Makefile')
-rw-r--r--graphics/pngquant/Makefile30
1 files changed, 13 insertions, 17 deletions
diff --git a/graphics/pngquant/Makefile b/graphics/pngquant/Makefile
index 6ccd140b97f7..97c5bfd00521 100644
--- a/graphics/pngquant/Makefile
+++ b/graphics/pngquant/Makefile
@@ -1,13 +1,8 @@
-# New ports collection makefile for: pngcquant
-# Date created: Fri 08 Feb 2002
-# Whom: Alex Hayward <xelah@xelah.com>
-#
+# Created by: Alex Hayward <xelah@xelah.com>
# $FreeBSD$
-#
PORTNAME= pngquant
-PORTVERSION= 1.7.2
-PORTREVISION= 1
+PORTVERSION= 1.8.1
DISTVERSIONSUFFIX= -src
CATEGORIES= graphics
MASTER_SITES= http://pngquant.org/
@@ -20,25 +15,26 @@ LICENSE_FILE= ${WRKSRC}/COPYRIGHT
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
-OPTIONS_DEFINE= OPTIMIZED_CFLAGS OPENMP SSE2 DEBUG DOCS
-OPENMP_DESC= Enable OpenMP support
-SSE2_DESC= Enable x86 SSE2 optimization
+OPTIONS_DEFINE= OPTIMIZED_CFLAGS OPENMP DEBUG DOCS
+OPTIONS_DEFINE_i386= SSE
-NO_WRKSUBDIR= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_BZIP2= yes
USE_CSTD= c99
-MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+USE_GMAKE= yes
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
MAKE_JOBS_SAFE= yes
-CFLAGS+= `libpng-config --I_opts`
-LDFLAGS+= `libpng-config --ldflags`
+CPPFLAGS+= $$(libpng-config --I_opts)
+LDFLAGS+= $$(libpng-config --ldflags) -lz -lm
MAN1= pngquant.1
PORTDOCS= CHANGELOG README.md
PLIST_FILES= bin/pngquant
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if empty(PORT_OPTIONS:MDEBUG)
CFLAGS+= -DNDEBUG
@@ -56,7 +52,7 @@ LDFLAGS+= ${PTHREAD_LIBS} -lgomp
.endif
# SSE2 support is always enabled on amd64
-.if ${PORT_OPTIONS:MSSE2} && ${ARCH} == "i386"
+.if ${PORT_OPTIONS:MSSE}
CFLAGS+= -DUSE_SSE=1 -msse2
.endif
@@ -69,4 +65,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README.md ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>