aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/pure-gl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/pure-gl/Makefile')
-rw-r--r--graphics/pure-gl/Makefile20
1 files changed, 4 insertions, 16 deletions
diff --git a/graphics/pure-gl/Makefile b/graphics/pure-gl/Makefile
index 133fdc82611d..b1537c4a49e9 100644
--- a/graphics/pure-gl/Makefile
+++ b/graphics/pure-gl/Makefile
@@ -7,31 +7,19 @@
PORTNAME= pure-gl
PORTVERSION= 0.8
+PORTREVISION= 1
CATEGORIES= graphics
-MASTER_SITES= http://pure-lang.googlecode.com/files/
MAINTAINER= lichray@gmail.com
COMMENT= Pure language interface to OpenGL
-LIB_DEPENDS+= pure.7:${PORTSDIR}/lang/pure
RUN_DEPENDS+= ${LOCALBASE}/lib/pure/ffi.pure:${PORTSDIR}/devel/pure-ffi
-LICENSE_FILE= ${WRKSRC}/COPYING
-
-USE_GMAKE= yes
+USE_PURE= yes
USE_GL= glut
-MAKE_ARGS+= prefix=${PREFIX} CPPFLAGS+=-I${LOCALBASE}/include LDFLAGS+=-L${LOCALBASE}/lib \
- CFLAGS="${CFLAGS}" LinkGL="-lglut -lGLU -lGL"
-
-PORTEXAMPLES= *
+MAKE_ARGS+= LinkGL="-lglut -lGLU -lGL"
.include <bsd.port.pre.mk>
-
-post-install:
-.if !defined(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}
- (cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
-.endif
-
+.include "${PORTSDIR}/lang/pure/bsd.pure.mk"
.include <bsd.port.post.mk>