aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/py-gvgen/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/py-gvgen/Makefile')
-rw-r--r--graphics/py-gvgen/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/graphics/py-gvgen/Makefile b/graphics/py-gvgen/Makefile
new file mode 100644
index 000000000000..ed67225c5f0e
--- /dev/null
+++ b/graphics/py-gvgen/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: py-gvgen
+# Date created: 19 May 2008
+# Whom: Sofian Brabez <sbrabez@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gvgen
+PORTVERSION= 0.9
+CATEGORIES= graphics python
+MASTER_SITES= http://software.inl.fr/releases/GvGen/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sbrabez@gmail.com
+COMMENT= An easy python interface to generate dot files
+
+USE_PYTHON= 2.5+
+USE_PYDISTUTILS=easy-install
+PYDISTUTILS_PKGVERSION= 0.9
+PYDISTUTILS_EGGINFO= GvGen-${PORTVERSION}-py${PYTHON_VER}.egg-info
+
+PORTDOCS= user-guide.tex.lyx
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/docs/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>