aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/py-matplotlib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/py-matplotlib/Makefile')
-rw-r--r--graphics/py-matplotlib/Makefile53
1 files changed, 0 insertions, 53 deletions
diff --git a/graphics/py-matplotlib/Makefile b/graphics/py-matplotlib/Makefile
deleted file mode 100644
index 9887931906f0..000000000000
--- a/graphics/py-matplotlib/Makefile
+++ /dev/null
@@ -1,53 +0,0 @@
-# ex:ts=8
-# Ports collection makefile for: py-matplotlib
-# Date created: Aug 4, 2004
-# Whom: ijliao
-#
-# $FreeBSD$
-#
-
-PORTNAME= matplotlib
-PORTVERSION= 0.60.2
-CATEGORIES= graphics python
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
-PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A plotting library uses a syntax familiar to matlab users
-
-BUILD_DEPENDS= ${PYNUMERIC} \
- ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter \
- ${LOCALBASE}/lib/libagg.a:${PORTSDIR}/graphics/agg
-LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
-RUN_DEPENDS= ${PYNUMERIC} \
- ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
-
-USE_PYTHON= 2.2+
-USE_PYDISTUTILS= yes
-USE_GNOME= gtk20 pygtk2
-CFLAGS+= -I${X11BASE}/include
-
-DATADIR= ${PREFIX}/share/py-${PORTNAME}
-EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
-
-PLISTDIR= ${PYTHON_SITELIBDIR}/${PORTNAME} ${DATADIR}
-.if !defined(NOPORTDOCS)
-PLISTDIR+= ${EXAMPLESDIR}
-.endif
-
-.include <bsd.port.pre.mk>
-
-post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${EXAMPLESDIR}
- ${CP} -R ${WRKSRC}/examples/ ${EXAMPLESDIR}
-.endif
-.for dir in ${PLISTDIR}
- @${FIND} ${dir} ! -type d | \
- ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
- @${FIND} ${dir} -type d | ${SORT} -r | \
- ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
-.endfor
-
-.include <bsd.port.post.mk>