aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/py-pycollada/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/py-pycollada/Makefile')
-rw-r--r--graphics/py-pycollada/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/graphics/py-pycollada/Makefile b/graphics/py-pycollada/Makefile
new file mode 100644
index 000000000000..00f5df23d546
--- /dev/null
+++ b/graphics/py-pycollada/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= pycollada
+PORTVERSION= 0.4.1
+CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= tj+freebsd_ports@a13.fr
+COMMENT= Python library for reading and writing collada documents
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>0:math/py-numpy \
+ ${PYTHON_PKGNAMEPREFIX}dateutil>=2.0:devel/py-dateutil
+
+NO_ARCH= yes
+USES= python
+USE_PYTHON= autoplist distutils
+
+OPTIONS_DEFINE= LXML
+
+LXML_DESC= Uses lxml for XML loading, construction, and saving.
+LXML_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>0:devel/py-lxml
+
+.include <bsd.port.mk>