aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/py-pygooglechart/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/py-pygooglechart/Makefile')
-rw-r--r--graphics/py-pygooglechart/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/graphics/py-pygooglechart/Makefile b/graphics/py-pygooglechart/Makefile
index 32d04dae3443..840bc1b2be0b 100644
--- a/graphics/py-pygooglechart/Makefile
+++ b/graphics/py-pygooglechart/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pygooglechart
PORTVERSION= 0.3.0
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= graphics python
MASTER_SITES= http://pygooglechart.slowchop.com/files/download/ \
LOCAL/nivit/${PORTNAME}/
@@ -12,18 +12,16 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= nivit@FreeBSD.org
COMMENT= Complete Python wrapper for the Google Chart API
-USE_PYTHON= yes
-USE_PYDISTUTILS= easy_install
-
-PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_AUTOPLIST= yes
PORTEXAMPLES= *
-
-.if !defined(NOPORTEXAMPLES)
EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
-NO_STAGE= yes
+
post-install:
- ${MKDIR} ${EXAMPLESDIR} && cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${EXAMPLESDIR}
-.endif
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR} && \
+ cd ${WRKSRC}/examples && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>