aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/py-visual/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/py-visual/Makefile')
-rw-r--r--graphics/py-visual/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/graphics/py-visual/Makefile b/graphics/py-visual/Makefile
index 3133500f47f3..9d086aca5199 100644
--- a/graphics/py-visual/Makefile
+++ b/graphics/py-visual/Makefile
@@ -7,6 +7,7 @@
PORTNAME= visual
PORTVERSION= 3.2.1
+PORTREVISION= 1
CATEGORIES= graphics python
MASTER_SITES= http://www.vpython.org/download/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -24,19 +25,29 @@ USE_GMAKE= yes
USE_GNOME= gtk12
USE_LIBTOOL_VER= 15
USE_PYTHON= 2.3+
+USE_REINPLACE= yes
USE_XLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-html-dir=${DOCSDIR} \
--with-example-dir=${EXAMPLESDIR}
+CONFIGURE_ENV= PYTHONPATH=${PYTHON_LIBDIR}
.if defined(NOPORTDOCS)
CONFIGURE_ARGS+= --disable-docs
.endif
+VPYTHON_SCRIPT= bin/vpython.in
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
BROKEN= "does not compile"
.endif
+post-patch:
+ @cd ${WRKSRC}; \
+ ${REINPLACE_CMD} -e 's|%%PYTHONBASE%%|${PYTHONBASE}|g' \
+ -e 's|%%PYTHON_VERSION%%|${PYTHON_VERSION:S/python//g}|g' \
+ ${VPYTHON_SCRIPT}
+
.include <bsd.port.post.mk>