aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/pygts
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/pygts')
-rw-r--r--graphics/pygts/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/graphics/pygts/Makefile b/graphics/pygts/Makefile
index ac84e86c09bc..8815e7e374bd 100644
--- a/graphics/pygts/Makefile
+++ b/graphics/pygts/Makefile
@@ -3,13 +3,16 @@
PORTNAME= pygts
PORTVERSION= 0.3.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics python
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Python binding for GNU Triangulated Surface(GTS) Library
+LICENSE= GPLv2 # or later
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
BUILD_DEPENDS= ${PYNUMPY}
RUN_DEPENDS= ${PYNUMPY}
LIB_DEPENDS= libgts.so:${PORTSDIR}/graphics/gts
@@ -17,4 +20,7 @@ LIB_DEPENDS= libgts.so:${PORTSDIR}/graphics/gts
USE_PYTHON= distutils
USES= pkgconfig python
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/gts/_gts.so
+
.include <bsd.port.mk>