aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/qtutils/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/qtutils/Makefile')
-rw-r--r--graphics/qtutils/Makefile6
1 files changed, 1 insertions, 5 deletions
diff --git a/graphics/qtutils/Makefile b/graphics/qtutils/Makefile
index ebdff61c3a84..e388d71a4a8e 100644
--- a/graphics/qtutils/Makefile
+++ b/graphics/qtutils/Makefile
@@ -21,6 +21,7 @@ LIB_DEPENDS= vorbis.2:${PORTSDIR}/audio/libvorbis \
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_GNOME= glib12
+USE_GETOPT_LONG= yes
USE_REINPLACE= yes
USE_LIBTOOL= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
@@ -31,11 +32,6 @@ MAN1= qtconv.1 qtsg.1 qtsplit.1
CPPFLAGS= -I${LOCALBASE}/include `${GLIB_CONFIG} --cflags gthread`
LDFLAGS= -L${LOCALBASE}/lib `${GLIB_CONFIG} --libs gthread`
-.if !exists(/usr/include/getopt.h)
-LIB_DEPENDS+= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
-LDFLAGS+= -lgnugetopt
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|-g -Wall|@CFLAGS@|g ; \
s|-lglib||g ; \