aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/s10sh/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/s10sh/Makefile')
-rw-r--r--graphics/s10sh/Makefile12
1 files changed, 4 insertions, 8 deletions
diff --git a/graphics/s10sh/Makefile b/graphics/s10sh/Makefile
index 0f8bcdae9a2d..07131ee9883c 100644
--- a/graphics/s10sh/Makefile
+++ b/graphics/s10sh/Makefile
@@ -21,17 +21,13 @@ PLIST_FILES= bin/${PORTNAME}
PORTDOCS= README
-OPTIONS_DEFINE= USB
+OPTIONS_DEFINE= USB DOCS
.include <bsd.port.pre.mk>
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
-
-post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.post.mk>