aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/sane-backends/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/sane-backends/Makefile')
-rw-r--r--graphics/sane-backends/Makefile46
1 files changed, 12 insertions, 34 deletions
diff --git a/graphics/sane-backends/Makefile b/graphics/sane-backends/Makefile
index 1d39d4f57d78..eafc4bd5ff95 100644
--- a/graphics/sane-backends/Makefile
+++ b/graphics/sane-backends/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= sane
-PORTVERSION= 1.0.1
+PORTVERSION= 1.0.2
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SUNSITE} \
ftp://ftp.mostang.com/pub/sane/
@@ -19,40 +19,18 @@ LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
-.include <bsd.port.pre.mk>
-
USE_GMAKE= yes
USE_LIBTOOL= yes
-.if ${OSVERSION} < 300000
-CONFIGURE_ENV= CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib" \
- GTK_CONFIG="${GTK_CONFIG}"
-.else
-CONFIGURE_ENV= CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib -lcam" \
- GTK_CONFIG="${GTK_CONFIG}"
-.endif
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ GTK_CONFIG="${GTK_CONFIG}" \
+ LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --disable-gtktest
-MAN1= scanimage.1 \
- xscanimage.1 \
- saned.1
-MAN5= sane-abaton.5 \
- sane-agfafocus.5 \
- sane-apple.5 \
- sane-dc25.5 \
- sane-dll.5 \
- sane-dmc.5 \
- sane-epson.5 \
- sane-hp.5 \
- sane-microtek.5 \
- sane-microtek2.5 \
- sane-mustek.5 \
- sane-net.5 \
- sane-pint.5 \
- sane-pnm.5 \
- sane-qcam.5 \
- sane-scsi.5 \
- sane-umax.5
+MAN1= saned.1 scanimage.1 xscanimage.1
+MAN5= sane-abaton.5 sane-agfafocus.5 sane-apple.5 sane-dll.5 sane-dc25.5 \
+ sane-dmc.5 sane-epson.5 sane-hp.5 sane-microtek.5 sane-microtek2.5 \
+ sane-mustek.5 sane-net.5 sane-pint.5 sane-pnm.5 sane-umax.5 \
+ sane-qcam.5 sane-scsi.5 sane-artec.5 sane-fujitsu.5 sane-sharp.5
pre-configure:
@${ECHO} "*** Note: SANE can be built with an X scanner interface"
@@ -61,6 +39,6 @@ pre-configure:
@${ECHO} "*** the GIMP and GTK packages/ports."
post-install:
- @${CAT} ${PKGDIR}/MESSAGE
+ @${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>