aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/sane-backends/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/sane-backends/Makefile')
-rw-r--r--graphics/sane-backends/Makefile66
1 files changed, 42 insertions, 24 deletions
diff --git a/graphics/sane-backends/Makefile b/graphics/sane-backends/Makefile
index f3b64087fa79..ad3725f5e1f1 100644
--- a/graphics/sane-backends/Makefile
+++ b/graphics/sane-backends/Makefile
@@ -1,17 +1,17 @@
-# New ports collection makefile for: sane-backends
-# Date created: Sat Jul 19 16:23:10 MET DST 1997
-# Whom: gary@hotlava.com
-#
+# Created by: gary@hotlava.com
# $FreeBSD$
-#
PORTNAME= sane-backends
-PORTVERSION= 1.0.22
-PORTREVISION= 2
+PORTVERSION= 1.0.23
CATEGORIES= graphics
-MASTER_SITES= http://alioth.debian.org/frs/download.php/3503/ \
- ftp://ftp2.sane-project.org/pub/sane/%SUBDIR%/
-MASTER_SITE_SUBDIR= ${PORTNAME}-${PORTVERSION}
+MASTER_SITES= http://alioth.debian.org/frs/download.php/3752/:3752 \
+ http://alioth.debian.org/frs/download.php/3753/:3753 \
+ http://alioth.debian.org/frs/download.php/3754/:3754 \
+ ftp://ftp2.sane-project.org/pub/sane/
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}.1:3752,DEFAULT \
+ ${DISTNAME}${EXTRACT_SUFX}.2:3753,DEFAULT \
+ ${DISTNAME}${EXTRACT_SUFX}.3:3754,DEFAULT
+EXTRACT_ONLY= # need to concatenate before extraction
MAINTAINER= ports@FreeBSD.org
COMMENT= API for access to scanners, digitals camera, frame grabbers etc
@@ -22,21 +22,23 @@ LICENSE_COMB= dual
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff
-OPTIONS_DEFINE= USB NLS GPHOTO2 SNMP AVAHI IEEE1284 IPV6 DOCS
+OPTIONS_DEFINE= USB GPHOTO2 SNMP AVAHI IEEE1284 IPV6 DOCS
OPTIONS_DEFAULT= USB
USB_DESC= USB support
GPHOTO2_DESC= gPhoto2 support
IEEE1284_DESC= libieee1284 support
+USE_GNOME= gnomehack
+USE_PKGCONFIG= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-docdir=${DOCSDIR} \
+CONFIGURE_ARGS= --with-docdir=${WRKDIR}/tmproot \
--disable-latex \
--disable-locking \
--enable-pthread
USE_LDCONFIG= yes
-MAKE_JOBS_UNSAFE= yes
+MAKE_JOBS_SAFE= yes
USE_RC_SUBR= saned
SUB_FILES+= pkg-message
@@ -50,13 +52,9 @@ LDFLAGS+= -L${LOCALBASE}/lib
.include "Makefile.man"
.include <bsd.port.pre.mk>
-.if empty(PORT_OPTIONS:MDOCS)
-MAKE_ENV+= NOPORTDOCS=1
-.endif
-
.if ${PORT_OPTIONS:MUSB}
.if ${OSVERSION} < 800069
-LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
+LIB_DEPENDS+= usb-0.1:${PORTSDIR}/devel/libusb
.endif
.else
CONFIGURE_ARGS+= --disable-libusb
@@ -75,7 +73,7 @@ CONFIGURE_ARGS+= --disable-ipv6
.endif
.if ${PORT_OPTIONS:MGPHOTO2}
-LIB_DEPENDS+= gphoto2.2:${PORTSDIR}/graphics/libgphoto2
+LIB_DEPENDS+= gphoto2:${PORTSDIR}/graphics/libgphoto2
MAN5+= sane-gphoto2.5
PLIST_SUB+= GPHOTO2=""
.else
@@ -84,29 +82,49 @@ PLIST_SUB+= GPHOTO2="@comment "
.endif
.if ${PORT_OPTIONS:MSNMP}
-LIB_DEPENDS+= netsnmp.30:${PORTSDIR}/net-mgmt/net-snmp
+LIB_DEPENDS+= netsnmp:${PORTSDIR}/net-mgmt/net-snmp
.else
CONFIGURE_ARGS+= --without-snmp
.endif
.if ${PORT_OPTIONS:MAVAHI}
-LIB_DEPENDS+= avahi-client.3:${PORTSDIR}/net/avahi-app
+LIB_DEPENDS+= avahi-client:${PORTSDIR}/net/avahi-app
CONFIGURE_ARGS+= --enable-avahi
.endif
.if ${PORT_OPTIONS:MIEEE1284}
-LIB_DEPENDS+= ieee1284.5:${PORTSDIR}/sysutils/libieee1284
+LIB_DEPENDS+= ieee1284:${PORTSDIR}/sysutils/libieee1284
PLIST_SUB+= IEEE1284=""
+MAN5+= sane-canon_pp.5 sane-hpsj5s.5 sane-mustek_pp.5
.else
CONFIGURE_ENV+= sane_cv_use_libieee1284=no
PLIST_SUB+= IEEE1284="@comment "
.endif
+.if ${PORT_OPTIONS:MCUPS}
+LIB_DEPENDS+= cups:${PORTSDIR}/print/cups-client
+.else
+CONFIGURE_ENV+= ac_cv_header_cups_cups_h=no
+.endif
+
+post-extract:
+ @((cd ${DISTDIR} && ${CAT} ${DISTFILES:C/:[^:]+$//}) | (cd ${WRKDIR} \
+ && ${EXTRACT_CMD} ${EXTRACT_BEFOR_ARGS} ${EXTRACT_AFTER_ARGS}))
+
post-patch:
- @${REINPLACE_CMD} -e '/^for ac_header in/s|libc.h||g ; \
- s|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/^for ac_header in/s|libc.h|cups/cups.h| ; \
+ s|-e .*/cups.h|"$$ac_cv_header_cups_cups_h" = "yes"| ; \
+ s|-pthread|${PTHREAD_LIBS}|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/^dist_doc_DATA/s|COPYING||' \
+ ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e '/^pkgconfigdir/s|@libdir@|@prefix@/libdata|' \
+ ${WRKSRC}/tools/Makefile.in
post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ @(cd ${WRKDIR}/tmproot && ${COPYTREE_SHARE} . ${DOCSDIR})
+.endif
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>