aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/shotwell
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/shotwell')
-rw-r--r--graphics/shotwell/Makefile9
-rw-r--r--graphics/shotwell/distinfo4
-rw-r--r--graphics/shotwell/files/patch-Makefile55
-rw-r--r--graphics/shotwell/files/patch-src_photos_GRaw.vala38
-rw-r--r--graphics/shotwell/files/patch-vapi_libraw.vapi19
-rw-r--r--graphics/shotwell/pkg-plist6
6 files changed, 28 insertions, 103 deletions
diff --git a/graphics/shotwell/Makefile b/graphics/shotwell/Makefile
index 7e0bf72537cf..a63a837a4299 100644
--- a/graphics/shotwell/Makefile
+++ b/graphics/shotwell/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= shotwell
-PORTVERSION= 0.10.1
-PORTREVISION= 2
+PORTVERSION= 0.11.6
CATEGORIES= graphics gnome
MASTER_SITES= http://www.yorba.org/download/shotwell/${PORTVERSION:R}/
@@ -20,12 +19,12 @@ LIB_DEPENDS= sqlite3:${PORTSDIR}/databases/sqlite3 \
gee.2:${PORTSDIR}/devel/libgee \
json-glib-1.0.0:${PORTSDIR}/devel/json-glib \
soup-2.4.1:${PORTSDIR}/devel/libsoup \
- gexiv2.0:${PORTSDIR}/graphics/gexiv2 \
+ gexiv2:${PORTSDIR}/graphics/gexiv2 \
exif.12:${PORTSDIR}/graphics/libexif \
gphoto2.2:${PORTSDIR}/graphics/libgphoto2 \
webkitgtk-1.0:${PORTSDIR}/www/webkit-gtk2 \
unique-1.0.2:${PORTSDIR}/x11-toolkits/unique \
- raw.5:${PORTSDIR}/graphics/libraw
+ raw.2:${PORTSDIR}/graphics/libraw
USE_BZIP2= yes
USE_GETTEXT= yes
@@ -38,7 +37,7 @@ CONFIGURE_ARGS= --prefix=${PREFIX} \
CONFIGURE_ENV+= --define=NO_CAMERA
INSTALLS_ICONS= yes
-GCONF_SCHEMAS= shotwell.schemas
+GLIB_SCHEMAS= org.yorba.shotwell.gschema.xml org.yorba.shotwell-extras.gschema.xml
post-patch:
@${REINPLACE_CMD} -E \
diff --git a/graphics/shotwell/distinfo b/graphics/shotwell/distinfo
index df207f959348..c69a17cdfc8c 100644
--- a/graphics/shotwell/distinfo
+++ b/graphics/shotwell/distinfo
@@ -1,2 +1,2 @@
-SHA256 (shotwell-0.10.1.tar.bz2) = f6ef4782780af201402afeaf8f9484d5579cedff75fbf07b22587bb7cef69893
-SIZE (shotwell-0.10.1.tar.bz2) = 1483679
+SHA256 (shotwell-0.11.6.tar.bz2) = fab71137f336536565ea18b94591eb81c4ac696f627fe3d5ff361c9a55397af8
+SIZE (shotwell-0.11.6.tar.bz2) = 1570860
diff --git a/graphics/shotwell/files/patch-Makefile b/graphics/shotwell/files/patch-Makefile
index 1c69b743c808..234d5784ecc3 100644
--- a/graphics/shotwell/files/patch-Makefile
+++ b/graphics/shotwell/files/patch-Makefile
@@ -1,31 +1,22 @@
---- Makefile.orig 2011-06-02 12:11:21.000000000 -0700
-+++ Makefile 2011-08-12 17:33:51.953748181 -0700
-@@ -264,7 +264,6 @@
- gstreamer-0.10 \
+--- Makefile.orig 2011-11-03 14:39:05.000000000 -0700
++++ Makefile 2012-02-02 16:27:40.000000000 -0800
+@@ -273,7 +273,6 @@
gstreamer-base-0.10 \
+ gstreamer-pbutils-0.10 \
gtk+-2.0 \
- gudev-1.0 \
libexif \
libgphoto2 \
libsoup-2.4 \
-@@ -296,7 +295,6 @@
- gstreamer-0.10 >= 0.10.28 \
+@@ -309,7 +308,6 @@
gstreamer-base-0.10 >= 0.10.28 \
+ gstreamer-pbutils-0.10 >= 0.10.32 \
gtk+-2.0 >= 2.18.0 \
- gudev-1.0 >= 145 \
libexif >= 0.6.16 \
libgphoto2 >= 2.4.2 \
libsoup-2.4 >= 2.26.0 \
-@@ -375,7 +373,7 @@
- $(EXPANDED_HELP_FILES) $(EXPANDED_HELP_IMAGES) apport/shotwell.py $(UNIT_RESOURCES) $(UNIT_MKS) \
- unitize.mk units.mk $(PC_INPUT) $(PLUGINS_DIST_FILES) \
- $(EXPANDED_THUMBNAILER_SRC_FILES)
--
-+
-
- DIST_TAR = $(PROGRAM)-$(VERSION).tar
- DIST_TAR_BZ2 = $(DIST_TAR).bz2
-@@ -420,7 +418,7 @@
+@@ -434,7 +432,7 @@
# if not available.
LIBRAW_CONFIG=./libraw-config
@@ -34,19 +25,7 @@
@ ./chkver min $(VALAC_VERSION) $(MIN_VALAC_VERSION) || ( echo 'Shotwell requires Vala compiler $(MIN_VALAC_VERSION) or greater. You are running' $(VALAC_VERSION) '\b.'; exit 1 )
$(if $(MAX_VALAC_VERSION),\
@ ./chkver max $(VALAC_VERSION) $(MAX_VALAC_VERSION) || ( echo 'Shotwell cannot be built by Vala compiler $(MAX_VALAC_VERSION) or greater. You are running' $(VALAC_VERSION) '\b.'; exit 1 ),)
-@@ -561,6 +559,11 @@
- mkdir -p $(DESTDIR)$(PREFIX)/share/gnome/help/shotwell/C/figures
- $(INSTALL_DATA) $(EXPANDED_HELP_IMAGES) $(DESTDIR)$(PREFIX)/share/gnome/help/shotwell/C/figures
- endif
-+ifndef DISABLE_SCHEMAS_INSTALL
-+ GCONF_CONFIG_SOURCE=xml:merged:/usr/local/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule misc/shotwell.schemas
-+ mkdir -p $(DESTDIR)$(SCHEMA_FILE_DIR)
-+ $(INSTALL_DATA) misc/shotwell.schemas $(DESTDIR)$(SCHEMA_FILE_DIR)
-+endif
- -$(foreach lang,$(CORE_SUPPORTED_LANGUAGES),`mkdir -p $(SYSTEM_LANG_DIR)/$(lang)/LC_MESSAGES ; \
- $(INSTALL_DATA) $(LOCAL_LANG_DIR)/$(lang)/LC_MESSAGES/shotwell.mo \
- $(SYSTEM_LANG_DIR)/$(lang)/LC_MESSAGES/shotwell.mo`)
-@@ -638,7 +641,6 @@
+@@ -660,7 +658,6 @@
# EXPANDED_SRC_FILES includes UNITIZE_INITS and UNITIZE_ENTRY
$(VALA_STAMP): $(EXPANDED_SRC_FILES) $(EXPANDED_VAPI_FILES) $(EXPANDED_SRC_HEADER_FILES)
@@ -54,20 +33,20 @@
@echo Compiling Vala code...
@mkdir -p $(BUILD_DIR)
@$(VALAC) --ccode --directory=$(BUILD_DIR) --basedir=src \
-@@ -655,10 +657,10 @@
+@@ -677,10 +674,10 @@
@
$(EXPANDED_OBJ_FILES): %.o: %.c $(CONFIG_IN) Makefile
- $(CC) -c $(VALA_CFLAGS) `$(LIBRAW_CONFIG) --cflags` $(CFLAGS) -o $@ $<
-+ $(CC) -c $(VALA_CFLAGS) $(CFLAGS) `pkg-config --cflags libraw` -o $@ $<
++ $(CC) -c $(VALA_CFLAGS) `pkg-config --cflags libraw` -o $@ $<
$(PROGRAM): $(EXPANDED_OBJ_FILES) $(RESOURCES) $(LANG_STAMP) $(THUMBNAILER_BIN)
-- $(CC) $(EXPANDED_OBJ_FILES) $(CFLAGS) $(RESOURCES) $(VALA_LDFLAGS) `$(LIBRAW_CONFIG) --libs` $(EXPORT_FLAGS) -o $@
-+ $(CC) $(EXPANDED_OBJ_FILES) $(CFLAGS) $(RESOURCES) $(VALA_LDFLAGS) `pkg-config --libs libraw` $(EXPORT_FLAGS) -o $@
+- $(CC) $(EXPANDED_OBJ_FILES) $(CFLAGS) $(LDFLAGS) $(RESOURCES) $(VALA_LDFLAGS) `$(LIBRAW_CONFIG) --libs` $(EXPORT_FLAGS) -o $@
++ $(CC) $(EXPANDED_OBJ_FILES) $(CFLAGS) $(LDFLAGS) $(RESOURCES) $(VALA_LDFLAGS) `pkg-config --libs libraw` $(EXPORT_FLAGS) -o $@
+ glib-compile-schemas misc
$(THUMBNAILER_BIN): $(EXPANDED_THUMBNAILER_SRC_FILES)
- $(VALAC) $(EXPANDED_THUMBNAILER_SRC_FILES) $(VALAFLAGS) -o $@ $(foreach pkg,$(THUMBNAILER_PKGS),--pkg=$(pkg))
-@@ -668,7 +670,6 @@
+@@ -691,7 +688,6 @@
.PHONY: $(PLUGINS_DIR)
$(PLUGINS_DIR): $(PLUGIN_VAPI) $(PLUGIN_HEADER) $(PLUGIN_DEPS)
@@ -75,12 +54,12 @@
@$(MAKE) --directory=$@ PLUGINS_VERSION="$(VERSION)" USER_VALAFLAGS="$(USER_VALAFLAGS)" \
PLUGIN_CFLAGS="$(PLUGIN_CFLAGS)"
-@@ -686,7 +687,7 @@
+@@ -709,7 +705,7 @@
glade: lib$(PROGRAM).so
lib$(PROGRAM).so: $(EXPANDED_OBJ_FILES) $(RESOURCES) $(LANG_STAMP)
-- $(CC) $(EXPANDED_OBJ_FILES) $(CFLAGS) $(RESOURCES) $(VALA_LDFLAGS) `$(LIBRAW_CONFIG) --libs` $(EXPORT_FLAGS) -shared -o $@
-+ $(CC) $(EXPANDED_OBJ_FILES) $(CFLAGS) $(RESOURCES) $(VALA_LDFLAGS) $(LDFLAGS) `pkg-config --libs libraw` $(EXPORT_FLAGS) -shared -o $@
+- $(CC) $(EXPANDED_OBJ_FILES) $(CFLAGS) $(LDFLAGS) $(RESOURCES) $(VALA_LDFLAGS) `$(LIBRAW_CONFIG) --libs` $(EXPORT_FLAGS) -shared -o $@
++ $(CC) $(EXPANDED_OBJ_FILES) $(CFLAGS) $(LDFLAGS) $(RESOURCES) $(VALA_LDFLAGS) `pkg-config --libs libraw` $(EXPORT_FLAGS) -shared -o $@
.PHONY: pkgcheck
pkgcheck:
diff --git a/graphics/shotwell/files/patch-src_photos_GRaw.vala b/graphics/shotwell/files/patch-src_photos_GRaw.vala
deleted file mode 100644
index 3f9655e9d3b3..000000000000
--- a/graphics/shotwell/files/patch-src_photos_GRaw.vala
+++ /dev/null
@@ -1,38 +0,0 @@
-$NetBSD: patch-src_photos_GRaw.vala,v 1.1 2011/07/31 17:37:01 gls Exp $
-
-Fix importing with libraw 0.13.6 & 0.13.7
-Taken from upstream: http://redmine.yorba.org/issues/3868
-
---- src/photos/GRaw.vala.orig 2011-05-26 23:43:17.000000000 +0000
-+++ src/photos/GRaw.vala
-@@ -110,8 +110,8 @@ public class ProcessedImage {
- }
-
- public ProcessedImage(LibRaw.Processor proc) throws Exception {
-- LibRaw.Result result;
-- image = proc.make_mem_image(out result);
-+ LibRaw.Result result = LibRaw.Result.SUCCESS;
-+ image = proc.make_mem_image(ref result);
- throw_exception("ProcessedImage", result);
- assert(image != null);
-
-@@ -122,8 +122,8 @@ public class ProcessedImage {
- }
-
- public ProcessedImage.from_thumb(LibRaw.Processor proc) throws Exception {
-- LibRaw.Result result;
-- image = proc.make_mem_thumb(out result);
-+ LibRaw.Result result = LibRaw.Result.SUCCESS;
-+ image = proc.make_mem_thumb(ref result);
- throw_exception("ProcessedImage.from_thumb", result);
- assert(image != null);
-
-@@ -280,7 +280,7 @@ private void throw_exception(string call
- if (result == LibRaw.Result.SUCCESS)
- return;
- else if (result > 0)
-- throw new Exception.SYSTEM_ERROR("System error %d: %s", (int) result, strerror(result));
-+ throw new Exception.SYSTEM_ERROR("%s: System error %d: %s", caller, (int) result, strerror(result));
-
- string msg = "%s: %s".printf(caller, result.to_string());
-
diff --git a/graphics/shotwell/files/patch-vapi_libraw.vapi b/graphics/shotwell/files/patch-vapi_libraw.vapi
deleted file mode 100644
index 63e0dc999bf1..000000000000
--- a/graphics/shotwell/files/patch-vapi_libraw.vapi
+++ /dev/null
@@ -1,19 +0,0 @@
-$NetBSD: patch-vapi_libraw.vapi,v 1.1 2011/07/31 17:37:01 gls Exp $
-
-Fix importing with libraw 0.13.6 & 0.13.7
-Taken from upstream: http://redmine.yorba.org/issues/3868
-
---- vapi/libraw.vapi.orig 2011-05-26 23:43:17.000000000 +0000
-+++ vapi/libraw.vapi
-@@ -182,9 +182,9 @@ public class Processor {
- public unowned ImageSizes get_sizes() { return sizes; }
- public unowned Thumbnail get_thumbnail() { return thumbnail; }
- [CCode (cname="libraw_dcraw_make_mem_image")]
-- public ProcessedImage make_mem_image(out Result result);
-+ public ProcessedImage make_mem_image(ref Result result);
- [CCode (cname="libraw_dcraw_make_mem_thumb")]
-- public ProcessedImage make_mem_thumb(out Result result);
-+ public ProcessedImage make_mem_thumb(ref Result result);
- public Result open_buffer(uint8[] buffer);
- public Result open_file(string filename);
- [CCode (cname="libraw_dcraw_process")]
diff --git a/graphics/shotwell/pkg-plist b/graphics/shotwell/pkg-plist
index 41b88faf4e35..2d06ce94430a 100644
--- a/graphics/shotwell/pkg-plist
+++ b/graphics/shotwell/pkg-plist
@@ -5,6 +5,7 @@ lib/shotwell/plugins/builtin/flickr.png
lib/shotwell/plugins/builtin/picasa.png
lib/shotwell/plugins/builtin/piwigo.png
lib/shotwell/plugins/builtin/piwigo_authentication_pane.glade
+lib/shotwell/plugins/builtin/piwigo_publishing_options_pane.glade
lib/shotwell/plugins/builtin/shotwell-publishing-extras.so
lib/shotwell/plugins/builtin/shotwell-publishing.so
lib/shotwell/plugins/builtin/shotwell-transitions.so
@@ -209,11 +210,14 @@ share/locale/zh_TW/LC_MESSAGES/shotwell.mo
%%DATADIR%%/ui/savedsearch.ui
%%DATADIR%%/ui/search_bar.ui
%%DATADIR%%/ui/set_background_dialog.glade
+%%DATADIR%%/ui/search_sidebar_context.ui
%%DATADIR%%/ui/shotwell.glade
%%DATADIR%%/ui/shotwell.xml
-%%DATADIR%%/ui/sidebar_default.ui
+%%DATADIR%%/ui/sidebar_default_context.ui
+%%DATADIR%%/ui/tag_sidebar_context.ui
%%DATADIR%%/ui/tags.ui
%%DATADIR%%/ui/trash.ui
+
@dirrm %%DATADIR%%/ui
@dirrm %%DATADIR%%/icons
@dirrm %%DATADIR%%