aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/swfdec
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/swfdec')
-rw-r--r--graphics/swfdec/Makefile4
-rw-r--r--graphics/swfdec/files/patch-player-swf_play.c11
2 files changed, 11 insertions, 4 deletions
diff --git a/graphics/swfdec/Makefile b/graphics/swfdec/Makefile
index 477096e68ffb..d2b7a3b0a11b 100644
--- a/graphics/swfdec/Makefile
+++ b/graphics/swfdec/Makefile
@@ -32,10 +32,6 @@ LDFLAGS= -L${LOCALBASE}/lib
.include <bsd.port.pre.mk>
-.if ${ARCH} != "i386"
-BROKEN= "Does not compile on !i386"
-.endif
-
post-patch:
@${REINPLACE_CMD} -e "s|sdl-config|${SDL_CONFIG:T}|g" ${WRKSRC}/configure
@${REINPLACE_CMD} -e "s|malloc\.h|stdlib.h|g" ${WRKSRC}/libswfdec/jpeg/sl_types.h
diff --git a/graphics/swfdec/files/patch-player-swf_play.c b/graphics/swfdec/files/patch-player-swf_play.c
new file mode 100644
index 000000000000..bb284c97e4d3
--- /dev/null
+++ b/graphics/swfdec/files/patch-player-swf_play.c
@@ -0,0 +1,11 @@
+--- player/swf_play.c.orig Mon Mar 29 11:43:50 2004
++++ player/swf_play.c Mon Mar 29 11:44:14 2004
+@@ -390,7 +390,7 @@
+ static gboolean input(GIOChannel *chan, GIOCondition cond, gpointer ignored)
+ {
+ char *data;
+- int bytes_read;
++ long bytes_read;
+ GError *error = NULL;
+ int ret;
+