aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/togl
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/togl')
-rw-r--r--graphics/togl/Makefile11
1 files changed, 1 insertions, 10 deletions
diff --git a/graphics/togl/Makefile b/graphics/togl/Makefile
index c3ee69ffcf61..3a9eb2137adc 100644
--- a/graphics/togl/Makefile
+++ b/graphics/togl/Makefile
@@ -14,22 +14,13 @@ COMMENT= Tk OpenGL widget
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= gmake tk
+USES= gmake tk:tea
USE_XORG= x11 xt xmu
USE_GL= gl
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-tk=${TK_LIBDIR} \
- --with-tcl=${TCL_LIBDIR} \
- --with-tclinclude=${TCL_INCLUDEDIR}
USE_LDCONFIG= yes
TOGL_INSTDIR= ${PREFIX}/lib/${DISTNAME}
-CPPFLAGS+= -I${TK_INCLUDEDIR}
-LDFLAGS+= -L${TK_LIBDIR}
-
-PLIST_SUB= TK_VER=${TK_VER}
-
OPTIONS_DEFINE= DOCS EXAMPLES
post-patch: