aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/visprint/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/visprint/Makefile')
-rw-r--r--graphics/visprint/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/graphics/visprint/Makefile b/graphics/visprint/Makefile
new file mode 100644
index 000000000000..53080ef57320
--- /dev/null
+++ b/graphics/visprint/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: visprint
+# Date created: 11 November 2006
+# Whom: stas
+#
+# $FreeBSD$
+#
+
+PORTNAME= visprint
+PORTVERSION= 2.0
+CATEGORIES= graphics
+MASTER_SITES= http://www.tastyrabbit.net/visprint/download/
+
+MAINTAINER= stas@FreeBSD.org
+COMMENT= Creates fractal fingerprint images based on any data
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -lpng
+
+MANCOMPRESSED= yes
+
+PLIST_FILES= bin/visprint
+
+MAN1= visprint.1
+
+do-build:
+ (cd ${WRKSRC} && ${CC} ${CFLAGS} -c visprint.c)
+ (cd ${WRKSRC} && ${CC} ${LDFLAGS} visprint.o -o visprint)
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/visprint ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/visprint.1.gz ${PREFIX}/man/man1
+
+.include <bsd.port.mk>