aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/white_dune
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/white_dune')
-rw-r--r--graphics/white_dune/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/graphics/white_dune/Makefile b/graphics/white_dune/Makefile
index 4614e452f447..8d13a532af89 100644
--- a/graphics/white_dune/Makefile
+++ b/graphics/white_dune/Makefile
@@ -17,6 +17,7 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= png:${PORTSDIR}/graphics/png \
jpeg:${PORTSDIR}/graphics/jpeg
+USE_REINPLACE= yes
USE_BISON= yes
USE_MESA= yes
USE_MOTIF= yes
@@ -27,9 +28,9 @@ MAN1= dune.1
post-patch:
@${GREP} -lR "malloc.h" ${WRKSRC} | ${XARGS} \
- ${PERL} -pi -e "s/malloc\.h/stdlib.h/g"
- @${PERL} -pi -e "s/values\.h/limits.h/g" ${WRKSRC}/stdafx.h
- @${PERL} -pi -e "s/alloca\.h/stdlib.h/g" ${WRKSRC}/NodeNurbsSurface.cpp
+ ${REINPLACE_CMD} -e "s/malloc\.h/stdlib.h/g"
+ @${REINPLACE_CMD} -e "s/values\.h/limits.h/g" ${WRKSRC}/stdafx.h
+ @${REINPLACE_CMD} -e "s/alloca\.h/stdlib.h/g" ${WRKSRC}/NodeNurbsSurface.cpp
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/dune ${PREFIX}/bin