aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/xawtv/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/xawtv/Makefile')
-rw-r--r--graphics/xawtv/Makefile87
1 files changed, 0 insertions, 87 deletions
diff --git a/graphics/xawtv/Makefile b/graphics/xawtv/Makefile
deleted file mode 100644
index 09a58584f9c8..000000000000
--- a/graphics/xawtv/Makefile
+++ /dev/null
@@ -1,87 +0,0 @@
-# New ports collection makefile for: xawtv
-# Date created: 03 March 2001
-# Whom: George Reid <greid@ukug.uk.freebsd.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= xawtv
-PORTVERSION= 3.86
-CATEGORIES= graphics
-MASTER_SITES= http://bytesex.org/xawtv/
-DISTNAME= ${PORTNAME}_${PORTVERSION}
-
-MAINTAINER= lehmann@ans-netz.de
-COMMENT= A TV viewing application and a few TV utilities
-
-BUILD_DEPENDS= iconv:${PORTSDIR}/converters/libiconv
-LIB_DEPENDS= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d \
- png.5:${PORTSDIR}/graphics/png \
- jpeg.9:${PORTSDIR}/graphics/jpeg \
- aa.1:${PORTSDIR}/graphics/aalib
-
-WRKSRC= ${WRKDIR}/${DISTNAME:S/_/-/}
-USE_MOTIF= yes
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USE_XPM= yes
-USE_X_PREFIX= yes
-USE_REINPLACE= yes
-CONFIGURE_ENV= LIBS="-L${PREFIX}/lib -L${LOCALBASE}/lib"
-MAKE_ENV= verbose=yes
-
-FILES_LIBJPEG= console/Subdir.mk debug/Subdir.mk x11/Subdir.mk
-
-MAN1= alevtd.1 dump-mixers.1 fbtv.1 mtt.1 motv.1 ntsc-cc.1 pia.1 \
- propwatch.1 radio.1 record.1 rootv.1 scantv.1 showriff.1 \
- streamer.1 subtitles.1 ttv.1 v4lctl.1 webcam.1 xawtv-remote.1 \
- xawtv.1
-MAN5= xawtvrc.5
-MAN8= v4l-conf.8
-
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_LIBDV)
-LIB_DEPENDS+= dv.3:${PORTSDIR}/multimedia/libdv
-CONFIGURE_ARGS+=--enable-dv
-PLIST_SUB+= DV=
-.else
-CONFIGURE_ARGS+=--enable-dv=no
-PLIST_SUB+= DV="@comment "
-.endif
-
-.if defined(WITH_MMX)
-CONFIGURE_ARGS+=--enable-mmx
-CFLAGS+= -DMMX=1
-.endif
-
-.if defined(WITH_LIBQTIME)
-CONFIGURE_ARGS+=--enable-quicktime
-LIB_DEPENDS+= quicktime.0:${PORTSDIR}/graphics/libquicktime
-PLIST_SUB+= QT=
-.else
-CONFIGURE_ARGS+=--enable-quicktime=no
-PLIST_SUB+= QT="@comment "
-.endif
-
-PLIST_SUB+= X11PREFIX=${X11BASE}
-
-pre-everything::
- @${ECHO} ""
- @${ECHO} "You may use the following build options:"
- @${ECHO} ""
- @${ECHO} " WITH_LIBDV=yes Enable reading/writing raw dv files"
- @${ECHO} " WITH_LIBQTIME=yes Enable quicktime support"
- @${ECHO} " WITH_MMX=yes Enable mmx support"
- @${ECHO} ""
-
-post-patch:
- @${REINPLACE_CMD} -e "s|/usr/X11R6|${X11BASE}|g" \
- -e "s|/usr/local|${LOCALBASE}|g" \
- -e "s|-lpthread|${PTHREAD_LIBS}|g" ${WRKSRC}/configure
-
-.for i in ${FILES_LIBJPEG}
- @${REINPLACE_CMD} -e "s|-ljpeg|-L${LOCALBASE}/lib -ljpeg|g" ${WRKSRC}/$i
-.endfor
-
-.include <bsd.port.post.mk>