aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/xmms-gdancer/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/xmms-gdancer/Makefile')
-rw-r--r--graphics/xmms-gdancer/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/graphics/xmms-gdancer/Makefile b/graphics/xmms-gdancer/Makefile
new file mode 100644
index 000000000000..0d224aed9860
--- /dev/null
+++ b/graphics/xmms-gdancer/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: xmms-gdancer
+# Date created: 2. Jul 2001
+# Whom: Alexander@Leidinger.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmms-gdancer
+PORTVERSION= 0.4.4
+CATEGORIES= audio
+MASTER_SITES= http://www.figz.com/gdancer/files/
+DISTNAME= gdancer-$(PORTVERSION)
+
+MAINTAINER= netchild@FreeBSD.org
+
+LIB_DEPENDS= xmms.3:${PORTSDIR}/audio/xmms \
+ gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
+
+USE_X_PREFIX= yes
+USE_GTK= yes
+INSTALLS_SHLIB= yes
+
+GNU_CONFIGURE= yes
+
+CONFIGURE_ARGS= --enable-pixbuf
+
+post-install:
+ -${RM} ${PREFIX}/lib/xmms/Visualization/gdancer.la
+ @${ECHO_CMD} +++
+ @${ECHO_CMD} Now you have to install some themes from http://www.figz.com/gdancer/themes.php
+ @${ECHO_CMD} into .xmms/gdancer_themes. If it does not exist in your HOME directory, just
+ @${ECHO_CMD} create it.
+
+.include <bsd.port.mk>