aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/xmms-nebulus/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/xmms-nebulus/Makefile')
-rw-r--r--graphics/xmms-nebulus/Makefile30
1 files changed, 22 insertions, 8 deletions
diff --git a/graphics/xmms-nebulus/Makefile b/graphics/xmms-nebulus/Makefile
index 55f5c97a050b..94e6a171b150 100644
--- a/graphics/xmms-nebulus/Makefile
+++ b/graphics/xmms-nebulus/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xmms-nebulus
-PORTVERSION= 0.3.0
+PORTVERSION= 0.5.0
CATEGORIES= graphics
MASTER_SITES= http://nebulus.tuxfamily.org/
@@ -17,18 +17,32 @@ BUILD_DEPENDS= xmms-config:${PORTSDIR}/multimedia/xmms
LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12
RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
-SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
-
USE_X_PREFIX= yes
USE_MESA= yes
USE_GNOME= gtk12
-GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_LIBTOOL= yes
USE_REINPLACE= yes
-CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
+
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${X11BASE}/include -I${LOCALBASE}/include"
+
+SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
+CONFIGURE_ENV+= SDL_CONFIG=${SDL_CONFIG}
+MAKE_ENV+= SDL_CONFIG=${SDL_CONFIG}
post-patch:
- @${REINPLACE_CMD} -e 's|SDL/SDL.h|SDL11/SDL.h|g; \
- s|SDL/SDL_thread.h|SDL11/SDL_thread.h|g' \
- ${WRKSRC}/src/nebulus.c
+ @${REINPLACE_CMD} -E -e \
+ 's|SDL/SDL.h|SDL11/SDL.h|; \
+ s|SDL/SDL_opengl.h|SDL11/SDL_opengl.h|; \
+ s|SDL/SDL_thread.h|SDL11/SDL_thread.h|' \
+ ${WRKSRC}/src/nebulus.h \
+ ${WRKSRC}/src/nebulus.c \
+ ${WRKSRC}/src/face_data.c \
+ ${WRKSRC}/src/child_data.c \
+ ${WRKSRC}/configure
+
+ @${REINPLACE_CMD} -e \
+ 's|-Wall||' \
+ ${WRKSRC}/src/Makefile.in
.include <bsd.port.mk>