aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/xmountains/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/xmountains/Makefile')
-rw-r--r--graphics/xmountains/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/graphics/xmountains/Makefile b/graphics/xmountains/Makefile
index 74746d214c86..423efa81d8d5 100644
--- a/graphics/xmountains/Makefile
+++ b/graphics/xmountains/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xmountains
PORTVERSION= 2.9
-CATEGORIES= graphics
+CATEGORIES= graphics x11
MASTER_SITES= ftp://ftp.uwsg.indiana.edu/linux/debian/pool/main/x/xmountains/ \
ftp://ftp.fi.netbsd.org/.m/mirrors1/archive.ubuntu.com/pool/universe/x/xmountains/ \
ftp://ftp.mirrorservice.org/sites/archive.raspbian.org/raspbian/pool/main/x/xmountains/ \
@@ -18,12 +18,11 @@ NO_WRKSUBDIR= yes
USE_XORG= xbitmaps x11
-MAN6= ${PORTNAME}.6
-PLIST_FILES= bin/${PORTNAME}
+PLIST_FILES= bin/${PORTNAME} \
+ man/man6/${PORTNAME}.6.gz
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
-NO_STAGE= yes
post-extract:
@${LN} -sf ${PORTNAME}.man ${WRKSRC}/${PORTNAME}.6
@@ -31,7 +30,7 @@ do-build:
cd ${BUILD_WRKSRC} && ${CC} ${CFLAGS} *.c -lX11 -lm -o ${PORTNAME}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.6 ${MAN6PREFIX}/man/man6
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.6 ${STAGEDIR}${MAN6PREFIX}/man/man6
.include <bsd.port.mk>