aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/maverik/Makefile4
-rw-r--r--graphics/maverik/files/patch-setup2
2 files changed, 1 insertions, 5 deletions
diff --git a/graphics/maverik/Makefile b/graphics/maverik/Makefile
index 7725cf854993..8173de3451bb 100644
--- a/graphics/maverik/Makefile
+++ b/graphics/maverik/Makefile
@@ -32,10 +32,6 @@ MANCOMPRESSED= no
.include <bsd.port.pre.mk>
-.if ${ARCH} != "i386"
-BROKEN= "does not compile on ${ARCH}"
-.endif
-
.if defined(WITH_PNG)
LIB_DEPENDS+= png:${PORTSDIR}/graphics/png
diff --git a/graphics/maverik/files/patch-setup b/graphics/maverik/files/patch-setup
index 8a36410c638f..6bfe6c99a665 100644
--- a/graphics/maverik/files/patch-setup
+++ b/graphics/maverik/files/patch-setup
@@ -25,7 +25,7 @@
OS="-DMAV_LINUX -DMAV_FREEBSD" # The Linux defs also work for FreeBSD with a few exceptions
- CFLAG=`echo $OS $OT`
- LD="ld -shared"
-+ CFLAG=`echo $OS $OT %%CFLAGS%%`
++ CFLAG=`echo $OS -fPIC %%CFLAGS%%`
+ LD="${CC} -shared %%PTHREAD_LIBS%%"
LEX="flex"
- YACC="bison -y"