aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/fotofix/Makefile9
-rw-r--r--graphics/p5-Convert-Color/Makefile3
-rw-r--r--graphics/p5-Geo-EOP/Makefile9
-rw-r--r--graphics/p5-Geo-GML/Makefile9
-rw-r--r--graphics/p5-Geo-Gpx/Makefile9
-rw-r--r--graphics/p5-Image-Grab/Makefile9
-rw-r--r--graphics/p5-Image-Size/Makefile3
7 files changed, 19 insertions, 32 deletions
diff --git a/graphics/fotofix/Makefile b/graphics/fotofix/Makefile
index dff584ce1eb9..ec6aa972997e 100644
--- a/graphics/fotofix/Makefile
+++ b/graphics/fotofix/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: fotofix
-# Date created: 7 August 2007
-# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
-#
+# Created by: Andrew Pantyukhin <infofarmer@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= fotofix
PORTVERSION= 0.01.1.79
@@ -19,7 +15,8 @@ RUN_DEPENDS= p5-Prima>=1.21:${PORTSDIR}/x11-toolkits/p5-Prima \
IPA>=1.03:${PORTSDIR}/graphics/IPA
USE_BZIP2= yes
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
NO_BUILD= yes
PLIST_FILES= bin/${PORTNAME}
diff --git a/graphics/p5-Convert-Color/Makefile b/graphics/p5-Convert-Color/Makefile
index 5b1aadd177c6..a47b0011bef0 100644
--- a/graphics/p5-Convert-Color/Makefile
+++ b/graphics/p5-Convert-Color/Makefile
@@ -13,7 +13,8 @@ RUN_DEPENDS= \
p5-List-UtilsBy>0:${PORTSDIR}/devel/p5-List-UtilsBy
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Convert::Color.3 \
Convert::Color::CMY.3 \
diff --git a/graphics/p5-Geo-EOP/Makefile b/graphics/p5-Geo-EOP/Makefile
index 38ea3bc841d7..cd1ef22662e1 100644
--- a/graphics/p5-Geo-EOP/Makefile
+++ b/graphics/p5-Geo-EOP/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Geo-EOP
-# Date created: 23 January 2009
-# Whom: Wen Heping <wenheping@gmail.com>
-#
+# Created by: Wen Heping <wenheping@gmail.com>
# $FreeBSD$
-#
PORTNAME= Geo-EOP
PORTVERSION= 0.13
@@ -22,6 +18,7 @@ RUN_DEPENDS= p5-Geo-GML>=0.12:${PORTSDIR}/graphics/p5-Geo-GML \
MAN3= Geo::EOP::Util.3 Geo::EOP.3
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/graphics/p5-Geo-GML/Makefile b/graphics/p5-Geo-GML/Makefile
index dfff3c94c971..25462c926568 100644
--- a/graphics/p5-Geo-GML/Makefile
+++ b/graphics/p5-Geo-GML/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Geo-GML
-# Date created: 11 January 2009
-# Whom: Wen Heping <wenheping@gmail.com>
-#
+# Created by: Wen Heping <wenheping@gmail.com>
# $FreeBSD$
-#
PORTNAME= Geo-GML
PORTVERSION= 0.15
@@ -22,6 +18,7 @@ RUN_DEPENDS= p5-Log-Report>=0.18:${PORTSDIR}/devel/p5-Log-Report \
MAN3= Geo::GML.3 Geo::GML::Util.3 Geo::GML::GeoPoint.3
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/graphics/p5-Geo-Gpx/Makefile b/graphics/p5-Geo-Gpx/Makefile
index 24142acf5caf..cbff713d5c8b 100644
--- a/graphics/p5-Geo-Gpx/Makefile
+++ b/graphics/p5-Geo-Gpx/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Geo-Gpx
-# Date created: 10 March 2009
-# Whom: Wen Heping <wenheping@gmail.com>
-#
+# Created by: Wen Heping <wenheping@gmail.com>
# $FreeBSD$
-#
PORTNAME= Geo-Gpx
PORTVERSION= 0.26
@@ -26,6 +22,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Geo::Gpx.3
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/graphics/p5-Image-Grab/Makefile b/graphics/p5-Image-Grab/Makefile
index 88514a8461aa..c7de8befc34f 100644
--- a/graphics/p5-Image-Grab/Makefile
+++ b/graphics/p5-Image-Grab/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Image-Grab
-# Date created: 8 April 2001
-# Whom: Anatoliy Dmytriyev <tolid@plab.ku.dk>
-#
+# Created by: Anatoliy Dmytriyev <tolid@plab.ku.dk>
# $FreeBSD$
-#
PORTNAME= Image-Grab
PORTVERSION= 1.4.2
@@ -21,7 +17,8 @@ BUILD_DEPENDS= p5-URI>=0:${PORTSDIR}/net/p5-URI \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
CONFIGURE_ENV= ${ECHO_CMD} "N" |
MAN3= Image::Grab.3
diff --git a/graphics/p5-Image-Size/Makefile b/graphics/p5-Image-Size/Makefile
index 199dd5af8e6b..60f3192802b2 100644
--- a/graphics/p5-Image-Size/Makefile
+++ b/graphics/p5-Image-Size/Makefile
@@ -10,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tolid@tolid.eu.org
COMMENT= Perl5 module to determine the size of images in several common formats
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= imgsize.1
MAN3= Image::Size.3